Ski-Doo Snowmobiles Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
hi so i was riding my 98 skidoo fourmula 3 600 triple ran fine till i thought it ran out of gas, i got it back to the house went and got gas, put gas in it went to pull it over then of course the recoil broke i fixed that last night. So i got pulling on it and no fire took 2 of the 3 plugs out no spark on either of the two. i already removed the cdi from under the motor and mounted it on my air box. 2 years ago. so not having any spark i pulled the air box out and was messing with the connections then i happen to grab my wires and seen that there was 4 wires grouned and worn through i fixed them wires and still no spark did I mess up the cdi or stator if anyone could help that would be awesome !

Thanks

Dan
 

·
Registered
Joined
·
4,656 Posts
You'll need a multi meter to test this completely...and the manual. After verifying all connections are sound, run the test from the book. That will help determine harness/cdi/stator.
 

·
Registered
Joined
·
4,656 Posts
It's a 98 FIII. You're gonna' need both. Shoot me your email and I'll send you a couple manuals.
 

·
Registered
Joined
·
4,656 Posts
If you've been on this site long enough you already know about the 98 e-problems. If not, browse through my content on pages 4 and 5 and you'll find plenty of reading about it. The systems are basically the same for all 98 triples so don't pass on reading about an FIII 700 or a Mach Z.
 

·
Registered
Joined
·
4,656 Posts
It really depends on what wires they are but yes this could happen.
 

·
Registered
Joined
·
148 Posts
I would pull your stator out first. They are known for burning out on these sleds. Look for hot spots, and or melted spots. very common
 

·
Registered
Joined
·
4,656 Posts
If you cooked wires coming from the stator to the cdi (4 wires I think) then I might suggest your stator is harmed. If they are wires from the cdi to coils or kill or ignition (7 wires or so) then I might suggest your cdi. If both wires from the stator and wires from the cdi then you may have damage to both components.

The manual I sent has a wiring diagram to help you know where those damaged wires go. Which are they?
 
1 - 12 of 12 Posts
Top