Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
From what I can gather from reading, the digital readout on the tach on my '04 440 can toggle between hours, odometer, and speedo. Is this correct? I can toggle it with the button, but the only thing that works is the hour meter. It does not register miles or speed when moving. There is a plug and wires connected to a sensor on the driveshaft under the secondary, which leads me to believe it should work. This is also a trail setup with the holeshot button removed. Is there something plugged/unplugged under the console that should/shouldn't be?
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Yup. And it should still register miles anyway, shouldn't it? With the trail conversion, I'm not really up on what plugs are and are not supposed to be plugged where, so maybe that's it. Or maybe the pickup sensor on the driveshaft is bad.
 

·
Flyin Fox Daddy X3
Joined
·
31,313 Posts
I would unbolt the sensor under the secondary and make sure all of the parts are in there. It is going to be a greasy mess. Did the speedo and odometer work before?

When we put extroverts on my drive shaft, we pressed the spacer down into the drive shaft and I had to wait while the new one was on order. I put it together without the parts and ran it to test the sled. Without those parts it looks like everything is hooked up right, but only the hour meter works.

Worth a look.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #5 ·
You may be onto something there Steve. I got this sled last April as partial trade for my '04 600SDI. I didn't get to ride it then, so this season has been my only time on it. I have around 650 miles on it so far, and only the hour meter has worked from the day I got it. Being an '04, I'm sure it originally had the black drivers, which were bad and were updated with new white ones (and subsequently updated with yet another set fo white ones). This has the white ones, although I don't know which variation, the update or the update to the update. Regardless, they've been changed, and maybe what you described is what happened to this. Not sure what I'll find when I get in there, as any speedo I've ever worked with has been cable driven. Thanks for the lead!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top