Ski-Doo Snowmobiles Forum banner
1 - 20 of 39 Posts

·
Registered
Joined
·
9,186 Posts
I don't have an HO, but I do have ring problems. ...1201 miles 03 800
 

·
Ski-Dooer
Joined
·
2,288 Posts
05 renegade 800 x, no ring problems.......so far
 

·
Registered
Joined
·
153 Posts
2003 600 H.O. Set of rings at 1200 mi.-fixed no questions asked, no deductable
2003.5 Blair Morgan 2300 miles no ring problems

 

·
Registered
Joined
·
209 Posts
04 800ho last year with 3600miles and no problems. Dealer installed new rings for the buyer this year and the tech told me there was signs of trouble just starting.(flaking)
 

·
Registered
Joined
·
731 Posts
tran-quill-icer said:
04 800ho last year with 3600miles and no problems. Dealer installed new rings for the buyer this year and the tech told me there was signs of trouble just starting.(flaking)
[snapback]273410[/snapback]​
I just read an article in snotech and BRP says all 2005 800 motors have the updated chrome rings. Also any ring flaking problems can be identified by an aprox 15lbs of compression loss. All rings for this motor that are sold by BRP are the updated rings and in addition to the updated better rings a severe duty or racing replacement is also available from BRP.
 

·
Registered
Joined
·
386 Posts
I wish I knew if I have a problem. Sled runs ok, but is underpowered in my opinion. When it was stock, I could barely beat my buddies 01 XC 800. I plan to take my raves off and look for flaking, but as for now, 1100 miles and I dont think I have a problem.

04 800X

Eric

banderantee said:


I freind has an 04 800HO with 2200 miles on it, no ring problems.
I have an 05 800PT some it sholdn't be an issue


[snapback]273842[/snapback]​
 

·
Registered
Joined
·
2,348 Posts
Almost 3000km's and no problems. So, not everyone has problems.....
 

·
Registered
Joined
·
147 Posts
01-800 still running strong, 03 fast in the trails, 04 gade 800 a blast, 05 machz pull start a little tough but too fast for night riding so far
 
1 - 20 of 39 Posts
Top