Ski-Doo Snowmobiles Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,957 Posts
Discussion Starter · #1 ·
It's under my 09 gade. Just left of center.
af4154f9003ec2fa25ba827a708d7ffc.jpg
c53c2301c66a79576ef684183274db43.jpg


Getting my summer to do list together.

Sent from my iPod touch using Tapatalk
 

·
Registered
Joined
·
11,244 Posts
in 09 some of the oetiker clamps would lose their grip when the hoses cooled off. Some were even replaced with screw type hose clamps. Should also check your front heat exchanger just in case.
 
  • Like
Reactions: isthatahemi

·
boost junkie
Joined
·
10,598 Posts
oil cooler
 

·
Semi-professional Opinion Maker
Joined
·
1,003 Posts
I had the same issue at the beginning of this season. It ended up being the squeeze type of hose clamp they use from the factory loosening up around the thermostat housing. I replaced the thermostat for the hell of it and replace all of the clamps with the screw type hose clamps and that solved my problem.

Just a warning, is a PITA to get to and replace all the clamps. I ended up removing the muffler, exhaust pipe, secondary clutch, air box and some dumb plastic shield behind the muffler so I so I could access everything.

Good luck, hope this helps.

EDIT: I didn't realize this was in the 4 stroke section haha. None of this may apply to your problem. Sorry
 

·
Registered
Joined
·
1,957 Posts
Discussion Starter · #8 ·
Is the oil clean two-stroke or exhaust residue? Oil/water pump shaft seals going bad??
It is (4 stroke) motor oil and antifreeze. It seems to leak when it sits. If it was leaking while it was running I think I would have had to have added fluids over the winter. I put about 1800 miles on it like that. The puddle was from one night and from watching it this winter I can say as long as the sled sits there it will not get any bigger. So as CVCOBRA1 said it looks like it leaks as it cools down. That would explain the antifreeze but there is oil too.
 

·
Certifiable Sledhead and Cybertruck Reservation Ho
Joined
·
4,212 Posts
If you haven't updated your oil cooler you should check it. They crack and/or warp. Mine started leaking around the 8000 miles mark.
 

·
Registered
Joined
·
1,957 Posts
Discussion Starter · #10 ·
The oil cooler update is defiantly on my list for this spring. I have been expecting that one. I have been reading posts about it for years. The only problem is that ever year the parts seemed to change, like longer bolts, thicker plates, then thicker gaskets, etc. So I am a little confused as to what parts need to be changed. I do not trust my local dealer to be any help on this so if anyone knows part numbers or has pictures of the currently accepted upgrade I would love to see it
 

·
boost junkie
Joined
·
10,598 Posts
thermostat is under the intake manifold but water pump and oil cooler are under exhaust manifold
 

·
Registered
Joined
·
1,957 Posts
Discussion Starter · #12 ·
I want to put in a later thermostat while I'm at it, I have heard the 09s are hotter than the rest. My sled has always overheated rather easily. If I can gain a little something there I will gladly take it.
 

·
Registered
Joined
·
1,060 Posts
Probably the oil cooler leaking. Mine was leaking coolant. Now my valve cover is seeping oil at 7k miles now.

First year sled stuff, Replacement oil cooler kit will probably be the most current update.
 
1 - 15 of 15 Posts
Top