Ski-Doo Snowmobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
hi guys, i've been running usi vx 301 project x skis with 10 inch carbides on my 03 440,set up for trail use only,its only my second ride on the rev chassis,i'm not getting good corning controll though,i had the front springs set at loosest position,turned in 2 inches from top on threaded area of shock, i tightened it up to 2 1/4 on the trail and it seemed better but still not great. then after a long run thru some semi rough trails in southern vermont,my ski exploded off the sled,luckily at slow speed because i still hit bars hard ! no suspension damage thank god,just my ego and 2 hours of waiting for help to pick me up out of the woods at night. i think i'm gonna put the stock flex skis back on and try some 10 inch shaper bars, looking for set up suggestions, i 'm running a 1.75 track not studded,dynamoe joes trail suspension set up,3 rd hole on the limiter straps. i see alot of revs out there carving corners in the same trails where i'm pushing into the turns, i want to get my set up right before i hurt myself, thanks
 

·
Registered
Joined
·
952 Posts
That is scary! If that happened at a high rate of speed ...


I would definitely contact USI (show them the pics). I wouldn't want to jump to any conclusions, but those are older mounts and if they can become fatigued and shatter like that, i think USI should be informed about it. I run SPX's with HP mounts.

Did you anodized or paint them? i can't tell for sure but i'm assuming you (or some other owner) did, because the rod ends are the same color.
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #4 ·
yes i painted them along with my a arms, upon further inspection, my lower a arm was tweaked back,it bent the grade 8 bolts,the arm and the crossmember seem ok though. real glad it let go at slow speed ! i think what might have caused it was the front bolt on my carbide failed and it pulled thru the ski skin and must have dug in tearing off the ski, the other side was getting ready to go too, i'm really surprised though,the trails had gotten rough with moguls but its not like i was snocrossing,the sled was sucking up everything fine. i did send usi pics and they contacted me today and said they would prorate my stuff towards new stuff,but at this point i would need 2 new skis,mounts and carbides, i ve got the brand new flex skis that came on the sled ready to go, plus i really wasnt that impressed with the usi's ,maybe the new spx's perform better,but the vx 301's didnt turn this sled good at all
 
1 - 4 of 4 Posts
Top