Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I'm installing heavier springs in my Legend and have it all apart. I purchased the heavy spring from the dealer and when I got the old springs out I noticed that they have the same markings on them and as the new springs. Looks like one yellow slash and 2 beige?? slashes. I don't want to install these new ones if they are the same. Anybody have any input? If these are the same is there any place that sells heavier springs?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
Update on the colors after a closer look.....
Old springs are yellow-red-red
New springs are yellow-green-blue.

Maybe I'm okay ?????

Boatman said:
I'm installing heavier springs in my Legend and have it all apart. I purchased the heavy spring from the dealer and when I got the old springs out I noticed that they have the same markings on them and as the new springs. Looks like one yellow slash and 2 beige?? slashes. I don't want to install these new ones if they are the same. Anybody have any input? If these are the same is there any place that sells heavier springs?
[snapback]698062[/snapback]​
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
iansmxz said:
my cd says they are the heavier ones...
[snapback]698137[/snapback]​
Thanks, I wonder how much heavier.. It still seems to have alot more sag than I expected even with the preload set all the way up. Of course with this lack of snow there is no way to test it right now.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top