Ski-Doo Snowmobiles Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter · #1 ·
Its been a 4 month wait/process but its finally running. Now I just have some carb and clutch tuning to do. I'll post some pictures. It sure pulls hard. I haven't held it open yet but the stock clutching wants to let the engine go up close to 9000 rpms so I've got to fix that.
 

Attachments

·
Registered
Joined
·
254 Posts
Discussion Starter · #2 ·
kirk700 said:
Its been a 4 month wait/process but its finally running. Now I just have some carb and clutch tuning to do. I'll post some pictures. It sure pulls hard. I haven't held it open yet but the stock clutching wants to let the engine go up close to 9000 rpms so I've got to fix that.
[snapback]260919[/snapback]​
More pics of the sled
 

Attachments

·
Registered
Joined
·
254 Posts
Discussion Starter · #3 ·
kirk700 said:
kirk700 said:
Its been a 4 month wait/process but its finally running. Now I just have some carb and clutch tuning to do. I'll post some pictures. It sure pulls hard. I haven't held it open yet but the stock clutching wants to let the engine go up close to 9000 rpms so I've got to fix that.
[snapback]260919[/snapback]​
More pics of the sled
[snapback]260936[/snapback]​
One more picture.
 

Attachments

·
Registered
Joined
·
3,877 Posts
4 months????? Is that the typical waiting period?
 

·
Registered
Joined
·
254 Posts
Discussion Starter · #5 ·
saltalarev said:
4 months????? Is that the typical waiting period?
[snapback]260965[/snapback]​
I don't know, you'd have to call RKT and ask them. I sent my cylinders to them in early September and got them back the third week of December.
 

·
Registered
Joined
·
254 Posts
Discussion Starter · #8 ·
ns503 said:
Did you get an answer to what looked like a problem (other thread)?
[snapback]261185[/snapback]​
The offset piston problem turned out to be the cylinder torqued down crooked.
The head bolt threads in the cylinders were full of machining debree. I had to run a tap all the way down each one twice to get it all out.
A third small issue came up when I went to connect the heated carb coolant line to the head and found out there was no port for it in the RKT head. I had to disassemble the head and drill and tap a hole for the fitting then put the head back on.
All in all, for $1,740.00, it could have came to me in much better condition.
I'm just glad its running good.
 

·
Registered
Joined
·
1,226 Posts
kirk700 said:
ns503 said:
Did you get an answer to what looked like a problem (other thread)?
[snapback]261185[/snapback]​
The offset piston problem turned out to be the cylinder torqued down crooked.
The head bolt threads in the cylinders were full of machining debree. I had to run a tap all the way down each one twice to get it all out.
A third small issue came up when I went to connect the heated carb coolant line to the head and found out there was no port for it in the RKT head. I had to disassemble the head and drill and tap a hole for the fitting then put the head back on.
All in all, for $1,740.00, it could have came to me in much better condition.
I'm just glad its running good.
[snapback]261420[/snapback]​
good to hear it's up and running. keep us posted.
 

·
Registered
Joined
·
2,002 Posts
kirk700 said:
ns503 said:
Did you get an answer to what looked like a problem (other thread)?
[snapback]261185[/snapback]​
The offset piston problem turned out to be the cylinder torqued down crooked.
The head bolt threads in the cylinders were full of machining debree. I had to run a tap all the way down each one twice to get it all out.
A third small issue came up when I went to connect the heated carb coolant line to the head and found out there was no port for it in the RKT head. I had to disassemble the head and drill and tap a hole for the fitting then put the head back on.
All in all, for $1,740.00, it could have came to me in much better condition.
I'm just glad its running good.
[snapback]261420[/snapback]​
I'd agree. Shouldn't have to be cleaning up like that. And that pic did look like the bore was off center. However, glad you're up and running, keep us posted, hope it kicks butt for you.
 
1 - 11 of 11 Posts
Top