Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
my mom has a 2005 600 sdi, and we had problems with it not starting, running weird.. so I brought it to a local dealer, who put it on the computer, and it came up with a bad temp sensor, and headlight relay.. which is on back order, the temp sensor is coming in friday hopefully, cause we are going riding this weekend, I have a 2004 800 non sdi, can i take my temp sensor, and swap it with hers, i know it won't work in mine either, but will it run since theres no sdi, and will my work in her sdi, so we can ride this weekend????, Thanks in advance
 

·
Registered
2013 XR 1200 Renegade X
Joined
·
1,434 Posts
nyrev800 said:
my mom has a 2005 600 sdi, and we had problems with it not starting, running weird.. so I brought it to a local dealer, who put it on the computer, and it came up with a bad temp sensor, and headlight relay.. which is on back order, the temp sensor is coming in friday hopefully, cause we are going riding this weekend, I have a 2004 800 non sdi, can i take my temp sensor, and swap it with hers, i know it won't work in mine either, but will it run since theres no sdi, and will my work in her sdi, so we can ride this weekend????, Thanks in advance
[snapback]731626[/snapback]​
Which temp sensor? The one in the can???
 

·
ITs WINTER!
Joined
·
7,497 Posts
If your talking EG temp sensor only the SDI's have them.

If your talking about coolant temp it should be the same.
 

·
Registered
Joined
·
1,756 Posts
06MXZXRenegade800 said:
If your talking EG temp sensor only the SDI's have them.

If your talking about coolant temp it should be the same.
[snapback]731685[/snapback]​
Agree
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Its the head temp sensor, so i should be able to swap them, and the sdi should run fine, because it needs to work for the sdi, and my 800 non sdi, will run too, with the bad sensor form the sdi, cause it dosen't need it to make it run??
 

·
ITs WINTER!
Joined
·
7,497 Posts
Being an '04 model, yes you should have no problem running yours without a temp sensor. AFAIK the sensor is just for a dummy light becuase its a non CC sled.

Swap them around and have some fun!
 
1 - 6 of 6 Posts
Top