Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
443 Posts
Discussion Starter · #1 ·
Went for a ride tonight and noticed early on that the digital readout switched over to the hour meter. The meter was rest to zero hours and would not change. I stopped for dinner and when I restarted it the digital readout would show a line moving in a circular motion, then it would read "SCALE". The check temperature, engine,and battery warning lights would stay illuminated. I tried shutting the engine down and restarting it, but I had the same results. I checked all the fuses under the hood and they looked good. The back lighting for all the gauges work and the fuel & temp gauges work fine. Anyone have any ideas for an easy fix to this? I really dont have the time to haul it up to the dealer. Thanks in advance for any suggestions.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #2 ·
Oh yea, When i started it up after dinner the tach and speedo needles quit working.
 

·
Registered
Joined
·
539 Posts
BOKMAN said:
Oh yea, When i started it up after dinner the tach and speedo needles quit working.
[snapback]288429[/snapback]​
Trip reset button stuck,,, play with it, and it'll release, and all will be good again

happenned to me in middle of nowhere, a little scary,,,
 

·
Registered
Joined
·
107 Posts
Hmm, that's funny, had that happen to my '03 Mxz ZX, dealer replaced the speedo head, that does kinda make sence, their may have been moisture in the head. That's why, perhaps, when you wiggle the reset botton it fixes the problem.
It may have been frozen.
 

·
Registered
Joined
·
85 Posts
Had the same thing happen with the speedo stuck on 60 and the tach on 6000 along with all the indicator lights going and the digital screen illuminated but blank. Had my dealer analyze the situation and then called BRP. Bottomline: the speedo was causing all the problem and has been scheduled for replacement. it seems the speedo sends signals to the tach so the tach was also affected with the speedo malfunction. I'll post again when I get the new speedo installed and we know whether this fixed my problems.
 

·
Registered
Joined
·
556 Posts
My cousin had this happen on his wife gade. Nice thing is no miles are registered while in scale mode. FYI
 

·
Registered
Joined
·
85 Posts
On my Mach Z the tip botton was also stuck. Happened after a night of frezzing rain followed by cold. Just wiggled it and it reset finally.
 
1 - 9 of 9 Posts
Top