Ski-Doo Snowmobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
153 Posts
Was on the home stretch with the family when the steering on my sled went to crap. Managed to limp it to the trailer and get it home to the garage for an inspection. After looking at the shop-manual last night I had a good idea that the "main tube" as labeled in the manual had come loose where the "retaining support" bolts to the frame. After a bit of digging around today I managed to find both lower and upper half bushings as well as one lock-washer. The one is cracked so I will replace both. The "retaining support" is still attached to the frame with the other bolt.

I guess the main question is can all of this be re-attached without pulling the motor? There is not much room in there. Has anyone had this happen to them before? Thanks in advance for your help/suggestions. I tried to attach a diagram but for some reason couldn't.
 

·
Registered
Joined
·
233 Posts
I had that happen a few weeks ago. You MIGHT be able to, but I just pulled the motor partway....unbolted it and lifted/shimmed it up enough to get a long extension in from the front. Worked out quite well, once I found a vaccuum line for the air pump that had poped off...

good luck!
nik
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #3 ·
Did a bit more digging last night and pulled off the recoil. If I shim it up a bit I should be able to get at it from that side. Now, if only the parts were here...
 

·
Registered
Joined
·
384 Posts
use exstentions and you can get it from the front IVE DONE IT dont get me wrong its not easy but its much quicker than pulling the motor
 
1 - 4 of 4 Posts
Top