Ski-Doo Snowmobiles Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
325 Posts
Discussion Starter · #1 ·
my 2009 gsx 1200 is having a problem starting when sitting over night. it turns over really good but has a hard time to fire up. you have to try it a few times times, turning it over for about 10 seconds each time. I do hear the pump run. its like it looses its prime or pressure. it never did this before it always fired up right away. the only thing I did was replace the cluster dash speedo with a used one, not sure if this is causing something. does this cluster dash need to be reset at the dealer?
 

·
Registered
Joined
·
2,972 Posts
It could have a injector that is leaking. Mine is also having trouble cold starting in the morning with the same issues. It starts, but takes 2 tries
 

·
Registered
Joined
·
2,254 Posts
Start with the simple things. Have you looked at your plugs lately?

If they have carbon on the insulator then the quality of the spark will suffer. This causes hard starting.

Let us know what you find. Picture would be nice.
 

·
Registered
Joined
·
325 Posts
Discussion Starter · #5 ·
Start with the simple things. Have you looked at your plugs lately?

If they have carbon on the insulator then the quality of the spark will suffer. This causes hard starting.

Let us know what you find. Picture would be nice.
plugs were changed last year when I did the stator
 

·
Registered
Joined
·
2,254 Posts
plugs were changed last year when I did the stator
Ok.

So you hear the pump run which means that pressure to the injectors is being created.

However injectors can become dirty. Have you ever tried some Seafoam in your fuel?

Do you run ethanol? If so you could have some water in your fuel. Try some non-ethanol fuel with that Seafoam and run that for 50-100 miles.

Again, stick with the easy stuff.

If that does not help then we are going to move to fuel filter then compression test.
 

·
Registered
Joined
·
325 Posts
Discussion Starter · #8 ·
never run ethanol. haven't used seafoam before but will try it and also I will change the outer filter.
 

·
boost junkie
Joined
·
10,598 Posts
seen bad cam sensor also cause issues

find a donor and do a swap to test
 
1 - 11 of 11 Posts
Top