Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
409 Posts
Discussion Starter · #1 ·
Thank God for DooTalk, as per my previous post which went to three pages, I finally got my speedo working again. Per the insistance of a couple of you, and an extra thanks to new2memxz670 for listing the part number, I changed the relay by the airbox and speedo now works fine. The thing is, this is one of the first things I tried, with a relay that I got from autozone. The autozone guy just matched up the pins as I didn't have a part number. When I plugged in that relay, the problem still existed. Tried swapping everything from my wifes sled, speedo and tach, speedo pickup, tried all wire unplugging that I could, all to no avail. Using Napa/ECHLIN AR143 relay and problem solved, don't know if the autozone relay is defective or a different layout, the plugs fit fine, so somthing to watch for. But once again guys, thanks very much,,,glma
 

·
Mod'n is my thing
Joined
·
6,288 Posts
Glad you fixed it. Those relays seem to fail quite a bit.

Now that you know the problem...you'll carry a spare with you.
The lights can completely go out with a bad relay....so nice to carry a spare on the trail.
 

·
Registered
Joined
·
5 Posts
Glad you fixed it. Those relays seem to fail quite a bit.

Now that you know the problem...you'll carry a spare with you.
The lights can completely go out with a bad relay....so nice to carry a spare on the trail.
I have the same problem start yesterday will try relays tonight. thanks for posting this!
I used to ride cat and the first thing I thought of was speedo sencer and bearing , I hope the relay fixes my problem. It made for a long ride worrying about the drive bearing crapping out.
 

·
I might be dumb, but I’m not stupid!
Joined
·
1,296 Posts
Just fixed the same problem on mine today, just the relay. (oh yeah and the carb boots as well)
 

·
Registered
Joined
·
5 Posts
Speedo is fixed!
Bought a relay from NAPA for $11
The thing is cheap though, trying to zip tie it in the cover came off the relay I had to tape it back together. I will get a spare.
Thanks for the great help.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top