Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have an 04 Rev-x with the 600sdi

pretty much stock except for a couple of small cosmetic things.

When running in KM it seems that the speedo reads about 20% high. Is their more than on speedo for these things. The sled is still under warrantee. (actualy it is new, I have only driven it for about 200km)

Thanks
 

·
Registered
Joined
·
186 Posts
zedman said:
I have an 04 Rev-x with the 600sdi

pretty much stock except for a couple of small cosmetic things.

When running in KM it seems that the speedo reads about 20% high. Is their more than on speedo for these things. The sled is still under warrantee. (actualy it is new, I have only driven it for about 200km)

Thanks
[snapback]257215[/snapback]​
My 05 Rev X speedo is way off compared to my GPS:
Speedo GPS
100mph 92mph
70mph 64mph
50mph 45mph

I have checked my GPS against radar guns and it has always been dead on. Curiously, the odometer agrees perfectly with my GPS, so I don't think track skip is the issue, the speedo cal is simply out to lunch. I have 1.25" track with studs, so slip should be minimal.
 
G

·
TT670 said:
Ive never been on a snowmobile that had an accurate speedo.
[snapback]257277[/snapback]​
I've seen Fire Cat's that are off by 1 mph which is darn good. My Doo is off. Showing 107 mph on the speedo is 103 on gps. The again my buddies RX 1 shows 127 mph and 115 on gps. Yikes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Thanks for the replies

The sled has a 1" track with 96 studs. Mostly I have been doing road running with it. I will be testing the speedo against the GPS this weekend. I also switched it from KM to MPH.

I will let you know.

Thanks
 
1 - 5 of 5 Posts
Top