Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
Got a 800r 2011 spark plug top are pitted and almost welded on. , it was fighting to idle. Anybody have this prob the sled only got 600 mile onit
 

·
Registered
Joined
·
360 Posts
Original plugs or replacements? I had the plug caps fail on my '09 XP and was told that it was caused by using the hollow tip plugs as replacements. The irony is that I bought them from the same source that gave me that guidance, and they didn't offer a choice when I bought them. Personally, I'd replace the plug wires when you replace those plugs, as it's relatively cheap. The wires pull out from the coil, as opposed to screw on caps. Get an extra plastic retaining clip or two, as the OEM one will break when you remove the wires and it's a bit of bi_ch getting the new one on without breaking it.
 

·
Registered
Joined
·
3,298 Posts
If the plugs have screw on caps, mine always came loose unless I tightened them slightly with a vise grip. Loose caps

can cause some issues and guessing maybe some spark jumping. For that reason for many years I have been

buying only plugs that have solid caps.

The other problem is the resistance between the coil and the plugs which used to be generally in plug caps and 5000 ohms.

They can go bad and 30000 ohms will shut her down above 5 or 6000 rpm. Sometimes that resistance is put in the plug wires.

Real simple thing to fix if you know and have a volt/ohm/meter to check it. Anybody that has a sled should have one, $30 bucks

for an adequate one.

Good Luck
 
1 - 6 of 6 Posts
Top