Ski-Doo Snowmobiles Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
1,483 Posts
Well with all the SDI problem posts it's not a good time for another one. But before I get into this I can honestly say I love my SDI and have had no problems with it fouling plugs or many of the other SDI related problems.
Second winter with the sled and it has 9235kms(5772miles) on the clock. The sled always started first pull cold or hot until last week. Even pushing the RER button would take two pulls to start cold and some times three when hot with a crack of the throttle to get it to fire up.
Last Friday had a crew in from Toronto and were running hard through MooseValley when 230kms into the trip the motor locks up tight. So here's the picture what doo you all think????

.......................................................................................................................

PISTON
 

·
Registered
Joined
·
2,002 Posts
Sorry to hear that nb, be sure to keep us posted. Might get up your way yet this winter, if this weather keeps going like this much longer.
 

·
Registered
Joined
·
1,483 Posts
Discussion Starter · #3 ·
Wow 100 hits on this thread and no speculators. What would caused an SDI to lean out and melt down?
One thing about tearing it down was I got a good look at the rings or the good one anyway. I have tried 6 or 7 pictures but can't get one clear enough to post.
I could not see any flaking at first glance but for two tiny black spots. I used a dentist pick and after picking at it awhile I got the chrome moly to flake off.
So should I go with Cudney pistons or BRP piston and re ring the other??

Thanks NS let me know if you get up this way....
 

·
Registered
Joined
·
1,406 Posts
nbrenegade,
While you're at that point you have to buy a new base gasket any way get the 5 holed one. Your stock one is 6 hole and you will see a little bit of performace for almost Zero extra dollars! With 5700 miles on the clock I'd say that second piston has had a good life. Replace them both with Cudney's piston kit. Then replace the piston rod bearings and you might see another 5700 miles.
05SDI
 

·
ITs WINTER!
Joined
·
7,497 Posts
Yes it was due time for a refresh anyways but you want to figure out what did this before you throw a new top end on it and do it again in 10 miles.

Im thinking possibly a crank seal...
 

·
Ka-RAY-Zeeee
Joined
·
5,301 Posts
Any unusual issues with idling prior to the burndown? High idle, low idle, not idling down after a 1/2-3/4 throttle run? Personally, with those miles I'd replace crank seals, pistons (2 ring design this time), rings, caged bearings (little end) etc... Do it right and ride it another 5000 miles or more. Better rebuild the clutches now also.

As far as the reason for this problem, hard to say...I'd check the injectors and carb boots.
 

·
Registered
Joined
·
17 Posts
The one thing that we have changed that I haven't seen a lot about is the fuel filter. They are supposed to be changed every year, in 2004 they had a service paper about the filters breaking apart after a while and then flowing down the fuel steam and then blocking a injector. Cheap insurance for once a year. 10,000km original engine never touched.
 

·
Registered
Joined
·
5,793 Posts
Oh now a $60 fuel filter is CHEAP??????????
 

·
Registered
Joined
·
17 Posts
It maybe $60 from BRP . We just go to Canadian Tire you can get then for $15, it is for a car but i haven't had a problem. We have 2 SDI still cheap insurance.
 

·
Certifiable Sledhead and Cybertruck Reservation Ho
Joined
·
4,212 Posts
nbrenegade said:
Well with all the SDI problem posts it's not a good time for another one. But before I get into this I can honestly say I love my SDI and have had no problems with it fouling plugs or many of the other SDI related problems.
Second winter with the sled and it has 9235kms(5772miles) on the clock. The sled always started first pull cold or hot until last week. Even pushing the RER button would take two pulls to start cold and some times three when hot with a crack of the throttle to get it to fire up.
Last Friday had a crew in from Toronto and were running hard through MooseValley when 230kms into the trip the motor locks up tight. So here's the picture what doo you all think????

.......................................................................................................................

PISTON
[snapback]689141[/snapback]​
Ski-Doo's knock sensor richens the mixture when it detects detonation, unlike other systems that retard timing when knocking happens. This if fine unless the deto is caused by a fuel flow problem in the first place and then the injectors are incapable of delivering sufficient fuel to rectify the lean condition. So anything that may have hampered fuel flow could be your culprit (iced injector, plugged filter, etc.).

Just my thoughts... I don't know much about these SDI contraptions
...
 

·
Registered
Joined
·
63 Posts
Im rebuilding the sdi thursday and noticed u mentioned the 5 hole instead of the six. What adv- disadv will i get and will i have 2 run strictily on 91+ octane. Is there anything else i should know b4 putting my motor back together? Tips- tricks? I also am looking 2 keep reliability, will the 5 hole effect it?

New crank
complete gasket kit
fuel filter
2 cylinders
spi pistons
bearings
oil filter
reeds and boots

also how should i break her in?
 

·
Super Moderator
Joined
·
29,356 Posts
Any chance the exhaust bolts were loose?
 

·
Registered
Joined
·
759 Posts
hey mark , bill cudney sent me a pic yesterday and guess whos engine it was , he said if i had of stopped driving mine would have only had the minimal damage that yours did , but thats what warranty is for.
 

·
Registered
Joined
·
1,483 Posts
Discussion Starter · #18 ·
keyman231 said:
hey mark , bill cudney sent me a pic yesterday and guess whos engine it was , he said if i had of stopped driving mine would have only had the minimal damage that yours did , but thats what warranty is for.
[snapback]692843[/snapback]​
I would guess it was a pic of my engine? Well I had no choice but to stop cause she went from 8000 to 0rpm in a heart beat, even smoked the belt. I never had one go down that dirty before so I thought I had hurt her bad.
As far as warranty I'm out since I bought it in April/04. Marlau Sport always did good by me said he would see what he could do. The good ring has minimal flaking so he told me to bring it in.
Right now my main concern is to get my sled up and running so I can get back to riding. Parts should be all here tomorrow or Friday. I'm going through the fuel system, drain what's left in the tank, new fuel filter, check the lines, fuel rail and injectors then it will be ride and check the plugs.
As far as Doo coming across with anything I look at it this way... Yes there is some flaking on the ring after 5700miles, did it cause the melt down? I highly doubt it. It's a 2stroke that gets over 20miles/gal so you're threading a fine line to begin with. We'll get it back together try to prevent it from happening again and enjoy the rest of the winter.........
 

·
Registered
Joined
·
2,523 Posts
Lean for sure..........
H2O in gas...... both sides (more than likely)
dirt..... (in Injectors maybe)
Fuel filter..... both side again (more than likely)
Exhaust bolt a very good one..... (not loose)
Boots..... (you already checked.. another good one)
I wouldnt call it normal wear or even from the flaking rings. So I would really lok into the fuel delivery system for that side and see if anything looks out of line...... Good luck and I guess be thankful you got over 5k on it before any problems. My 2006 Summit HMX only got 121 miles on it before it melted down!!!!!!!
 
1 - 20 of 30 Posts
Top