Ski-Doo Snowmobiles Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
HEY I AM LOOKING FOR SOME HELP SKI DOO HAS LEFT ME HANGIN!! MY 2004 X 600SDI REV SLED HAS BEEN A LEMON IT WENT TO THE SHOP 7 TIMES LAST YEAR BEFORE THEY FOUND BAD RINGS!!! 800 MILES WITH BAD RINGS!! UNDER WARRANTY FIXED THIS YEAR 400 MILES PLUGS FOULING EXTREME BACKFIRING STALLING YOU NAME IT BACK TO THE SHOP BAD RINGS!!!! UNDER WARRANTY BEING FIXED AS WE SPEAK SUPPOSED NEW TYPE OF RING. I WANT TO KNOW HOW IT IS POSSIBLE TO HAVE 1200 MILES ON A SLED WITH BAD RINGS AND NOT DO OTHER DAMAGE THAT WILL MOST LIKELY SHOW AFTER MY WARRANTY IS GONE!!!! THIS SLED HAS CONSTANT PROBLEMS I MEAN AT WHAT POINT IS AN $8,000.00 SLED A LEMON. TAKE INTO CONSIDERATION THAT THIS SLED IS ALSO MY ONLY MEANS OF TRANSPORT!!! I AM WALKING WITH MY SLED IN THE SHOP I PAID $8,000.00 TO WALK!!!!! CAN SOMEONE TELL ME IF I AM LOOKING AT CONSTANT REPAIRS DUE TO THE FACT THAT I HAVE HAD BAD RINGS FROM DAY 1?????? I HAVE RIDDEN SKI DOO FOR YEARS!! I HAVE "SOLD" ABOUT 20 SLEDS FOR SKIDOO BY RECOMMENDING THEM ! SOMEONE RESTORE MY FAITH BECAUSE RIGHT NOW SKIDOO SUCKS
 

·
Registered
Joined
·
3,877 Posts
take a breath. You sled will be fine with the new rings. I see this is your first post. Do a search on "rings" and prepare to fall off your chair.
 

·
Registered
Joined
·
276 Posts
kim said:
HEY I AM LOOKING FOR SOME HELP SKI DOO HAS LEFT ME HANGIN!! MY 2004 X 600SDI REV SLED HAS BEEN A LEMON IT WENT TO THE SHOP 7 TIMES LAST YEAR BEFORE THEY FOUND BAD RINGS!!! 800 MILES WITH BAD RINGS!! UNDER WARRANTY FIXED THIS YEAR 400 MILES PLUGS FOULING EXTREME BACKFIRING STALLING YOU NAME IT BACK TO THE SHOP BAD RINGS!!!! UNDER WARRANTY BEING FIXED AS WE SPEAK SUPPOSED NEW TYPE OF RING. I WANT TO KNOW HOW IT IS POSSIBLE TO HAVE 1200 MILES ON A SLED WITH BAD RINGS AND NOT DO OTHER DAMAGE THAT WILL MOST LIKELY SHOW AFTER MY WARRANTY IS GONE!!!! THIS SLED HAS CONSTANT PROBLEMS I MEAN AT WHAT POINT IS AN $8,000.00 SLED A LEMON. TAKE INTO CONSIDERATION THAT THIS SLED IS ALSO MY ONLY MEANS OF TRANSPORT!!! I AM WALKING WITH MY SLED IN THE SHOP I PAID $8,000.00 TO WALK!!!!! CAN SOMEONE TELL ME IF I AM LOOKING AT CONSTANT REPAIRS DUE TO THE FACT THAT I HAVE HAD BAD RINGS FROM DAY 1?????? I HAVE RIDDEN SKI DOO FOR YEARS!! I HAVE "SOLD" ABOUT 20 SLEDS FOR SKIDOO BY RECOMMENDING THEM ! SOMEONE RESTORE MY FAITH BECAUSE RIGHT NOW SKIDOO SUCKS
[snapback]263867[/snapback]​
because the 03 and 04 revs had crappy rings, and your dealer probably just fialed to put the updated rings in. bye cudney's rings and throw them in
 

·
Registered
Joined
·
262 Posts
Have Rings been the source of all your problems? If so, then all you need to do is fix the ring issue, and then you should be set.

SkiDoo is supposed to have new type rings in the 2005's. Hopefully they update yours when they do the work.

If not, you can get rings from Big John, or Cudney's that solve the problem.

When I looked at buying a used Doo, I researched here for the most common problems, and rings are it. Before I rode the machine, I replaced mine with Cudney's. The ones I pulled out were pitted, and I don't know if or how many times the rings were changed before I got it. But so far, the sled has been great.

Other than rings, have you had other problems?
 

·
Registered
Joined
·
65 Posts
no problem my 2003 600 had bad rings at about 1000 miles and ski-doo covered it even though my warranty had ended.it also needed a pot and piston. this is a very common problem
 

·
Crazy Person
Joined
·
5,615 Posts
kim kim kim!!

Welcome to the club. Please take the time to search posts by myself and Deadman. We had the worst SDI's on this board. Deepsnow now ownes the one I had, Deadman still has his.

You aren't alone. On a plus note, the new sled I purchased has the new rings and it has held up with 5000 km's on it so far.

The new rings may help you in some ways, but the plug fouling isn't cured yet, but it is always being worked on according to BRP.

My suggestion to you, if it really is a lemon, get rid of it.
 
G

·
saltalarev said:
You sled will be fine with the new rings.
I thought so too. 400 miles on the new chrome nitrite rings and 30 % leakage on the pto side and between 30 and 35% on the mag side.
 

·
Registered
Joined
·
3,816 Posts
rob7374 said:
saltalarev said:
You sled will be fine with the new rings.
I thought so too. 400 miles on the new chrome nitrite rings and 30 % leakage on the pto side and between 30 and 35% on the mag side.
[snapback]265282[/snapback]​
Rob7374, You still have 30-35% leakdown after the chrome nitrate rings? I thought the 05 chrome rings were the fix?
 

·
Registered
Joined
·
3,877 Posts
rob7374 said:
saltalarev said:
You sled will be fine with the new rings.
I thought so too. 400 miles on the new chrome nitrite rings and 30 % leakage on the pto side and between 30 and 35% on the mag side.
[snapback]265282[/snapback]​
YIKES, good thing I bought Cudney's...
 
G

·
Rotax! said:
rob7374 said:
saltalarev said:
You sled will be fine with the new rings.
I thought so too. 400 miles on the new chrome nitrite rings and 30 % leakage on the pto side and between 30 and 35% on the mag side.
[snapback]265282[/snapback]​
Rob7374, You still have 30-35% leakdown after the chrome nitrate rings? I thought the 05 chrome rings were the fix?
[snapback]265359[/snapback]​
I had next to no leakage for the first 350 miles or so. Then suddenly it just wouldn't pull any weight in the primary. Checked the rings and wow. Thought it was the fix but obviously not. Gonna see if we can blow it up big time now.
 

·
Registered
Joined
·
1,204 Posts
Rings? People are having ring problems LOL. Welcome to the club. Here's hoping they put the chrome rings this time. If they did, you won't be waling anymore. Get them to check the crank seal too.
 

·
Registered
Joined
·
3,816 Posts
rob7374 said:
Rotax! said:
rob7374 said:
saltalarev said:
You sled will be fine with the new rings.
I thought so too. 400 miles on the new chrome nitrite rings and 30 % leakage on the pto side and between 30 and 35% on the mag side.
[snapback]265282[/snapback]​
Rob7374, You still have 30-35% leakdown after the chrome nitrate rings? I thought the 05 chrome rings were the fix?
[snapback]265359[/snapback]​
I had next to no leakage for the first 350 miles or so. Then suddenly it just wouldn't pull any weight in the primary. Checked the rings and wow. Thought it was the fix but obviously not. Gonna see if we can blow it up big time now.
[snapback]265418[/snapback]​
Rob7374, it sounds like maybe you got a bad batch or last years rings. Can you visually see the difference between the 04 rings and the 05?
 
G

·
Rotax! said:
Rob7374, it sounds like maybe you got a bad batch or last years rings. Can you visually see the difference between the 04 rings and the 05?
[snapback]265570[/snapback]​
It's a possibility that something like that happened. I did not compare the new style to the old style though. Sucks thats all I know.
 

·
Crazy Person
Joined
·
5,615 Posts
Well mine have held up in the PTEK, last year my sled blew up long before the miles I have now on the 05.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #15 ·
hey got my sled back after the 2nd ring change this time they put in the "new" kind it's running but it sounds different not bad but different than ever b 4 thanks for all the encouragement
 

·
Registered
Joined
·
33 Posts
I had an '04 rev 800 and the rings went out at 3200 miles. I called Tech support and they said to check for an antifreeze leak, so I did and there was a leak that was sucking air into the cooling system as they had suggested. Which in turn made an air bubble that got into the water pump and heated the motor which broke the rings. When I found the leak it was bad clamps under the gas tank, no antifreeze was leaking.
 
1 - 16 of 16 Posts
Top