Ski-Doo Snowmobiles Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter · #1 ·
THIS MONDAY NIGHT I DECIDED TO TAKE THE ADVICE FROM MANY ON THIS SITE AND REPLACE MY RINGS. I HAVE A 04 800 HO AND DID NOT EXPECT TO SEE ANY PROBLEMS. THE MACHINE HAS ABOUT 1000 MILES ON IT. EVERYTHING WAS WORKING FINE (STARTS EASILY, RER WORKS, AND NO LOSS OF POWER). PULLED THE JUGS OFF AND, YUP, FLAKING RINGS. SO I GUESS MY MESSAGE IS TO DO THE RINGS NO MATTER WHAT!!! DON'T CHANCE IT!!! THE RINGS I USED WERE FROM THE 05 DOO 800 MOD. THIS IS CHEAP INSURANCE.
 

·
Registered
Joined
·
5,793 Posts
Anybody have a HORSE and a STICK so we can beat on it some more?
 

·
Registered
Joined
·
378 Posts
RATED_X said:
will the ring work in a non ho motor,if so do you have the p/n.my 03 800 just hit 1000 miles this past weekend. thanx donnie
[snapback]295401[/snapback]​
I had the open mod rings put in my 03.5 BM 800 by the dealer. So the answer to you question is yes.
 

·
Crazy Person
Joined
·
5,618 Posts
Deadman said:
Anybody have a HORSE and a STICK so we can beat on it some more?

[snapback]295417[/snapback]​
Hmmmm, there's a stick in the closet next to me....now to find a horse...OHHH HONEY, COME TO THE COMPUTER.....


I'm not married...wonder why eh? LOL
 

·
Registered
Joined
·
546 Posts
Yellowknife said:
Deadman said:
Anybody have a HORSE and a STICK so we can beat on it some more?

[snapback]295417[/snapback]​
Hmmmm, there's a stick in the closet next to me....now to find a horse...OHHH HONEY, COME TO THE COMPUTER.....


I'm not married...wonder why eh? LOL
[snapback]295857[/snapback]​
WHAT???NOT MARRIED YET??? obviously you don't have any ring problems then eh??? better check em out...then you may have spares to get married with!! just make sure the rings DON'T fit here eh??!!lol...
 

·
734 Power
Joined
·
2,600 Posts
ViperER said:
THIS MONDAY NIGHT I DECIDED TO TAKE THE ADVICE FROM MANY ON THIS SITE AND REPLACE MY RINGS.
that was bad advice to begin with.

leave well enough alone!

when it brakes fix it... (many will see they they never break!)
[snapback]295714[/snapback]​
Your kidding right? Bad rings are a time bomb waiting to blow. When rings get bad they can damage your cylinders, I have seen it many times.....Its darn cheap insurance to change the stockers out. PLus the fact that once you loose compression....You loose POWER!
 

·
Registered
Joined
·
165 Posts
REV_X said:
ViperER said:
THIS MONDAY NIGHT I DECIDED TO TAKE THE ADVICE FROM MANY ON THIS SITE AND REPLACE MY RINGS.
that was bad advice to begin with.

leave well enough alone!

when it brakes fix it... (many will see they they never break!)
[snapback]295714[/snapback]​
Your kidding right? Bad rings are a time bomb waiting to blow. When rings get bad they can damage your cylinders, I have seen it many times.....Its darn cheap insurance to change the stockers out. PLus the fact that once you loose compression....You loose POWER!
[snapback]295927[/snapback]​
ya beat me to it was going to say the same thing , fix them now be for the bomb
takes the motor out , i think most of us know the 03 04 rings are junk , think about it if there was nothing wrong with them y did brp put crome rings in the 05 ,s
 

·
Registered
Joined
·
322 Posts
Discussion Starter · #13 ·
THE RINGS I INSTALLED WERE DOO'S PART #420-815-360. I ALSO OPTED FOT THE THINNER BASE GASKET FOR A BIT MORE COMPRESSION. I AM AWARE IT SEEMS AS IF THIS TOPIC HAS BEEN BEATEN TO DEATH, BUT I AM JUST TRYING TO SAVE SOME PEOPLE FROM A SERIOUS HEADACHE DOWN THE ROAD. IN MY CASE THERE WAS ABSOLUTELY NO INDICATION OF RING FAILURE UNTIL I REMOVED THE JUGS. GOOD LUCK!!!!!!!
 

·
Vendor
Joined
·
4,818 Posts
My Trail Torquer kit includes the chrome rings,base gasket,reed spacers,rave springs,jets,plugs and tuning instructions...all for $195 and it also cures the 5000 rpm stumble...BJ
 

·
Registered
Joined
·
386 Posts
I'm changing rings in my 04 800 right now, with 1400 miles, and I'm glad I decided to just do it because if I had waited until 2k plus miles, I'd not only be changing pistons as well, but it wouldnt be getting done under warranty.

Eric
 

·
Registered
Joined
·
386 Posts
The sled was running fine to me, until I put in a clutch kit. It would only hit 8k and stay there with no traction. Any other time, it would drop down to 7500, or never make it past 7500.

I did a cold/hot compression test and lost 6 & 9 psi, so I took it apart.

Eric

1SLEDHEAD said:
ERIC, ANY SYMPTOMS OF RING FAILURE, OR DID YOU JUST DECIDE TO DO IT???
[snapback]300168[/snapback]​
 

·
Registered
Joined
·
483 Posts
Guys not trying to stir the pot but we have done probably 7 sleds in the past 4-5 weeks on guys that were afraid of ring failure on 03-04 rev 800,s and I have to say they ranged from 600-3500 miles and not one had any bad rings not a one I am happy to get the buisness but I am starting to think the 800,s just are not having the problem, we have done quite a few 600,s and some have had bad rings flaking sticking what everyone has been reporting we have seen on the 600,s but not 800 I guess my point is for the 800 guys maybe it would be worth waiting to see if you devlope symptoms, I know before some jump on me you run the risk of blowing up your motor and all that but I am just not seeing it on the 800,s mho would be its a little hysteria ,, like the saying says if it aint broke.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top