Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
I've been hearing so many complaints about rings on the 600HO motors I was wondering if I should be worried on my 500ss. I know its not the 600HO motor but it is the old 600 motor. Anyone know if this problem exists on these machine.

Thanks
 

·
Crazy Person
Joined
·
5,615 Posts
Nope! You are safe.
 

·
Registered
Joined
·
5,435 Posts
It does not exist to the degree that it does on the HO.
 

·
Registered
Joined
·
8,113 Posts
there is only a minimal problem with PROPERLY used 600s anyway, and your 500SS is not immune to "normal" two-stroke failures...

contrary to all the CRAP you read!

ride it, if it breaks fix it!
 

·
Registered
Joined
·
1,064 Posts
ViperER said:
there is only a minimal problem with PROPERLY used 600s anyway, and your 500SS is not immune to "normal" two-stroke failures...

contrary to all the CRAP you read!

ride it, if it breaks fix it!
[snapback]295690[/snapback]​
Vipe, get a grip. I guess ignorance is bliss and you wish everyone to live in your blissful rose-colored world? In any event, every bit of advice (CRAP) you give out regarding ring issues is horrible advice. If a poll was done I bet 98% out of 50 people being polled would agree. The 2% being your own vote....

But for the record, no ring probs with 500SS!
 

·
Registered
Joined
·
1,064 Posts
ViperER said:
there is only a minimal problem with PROPERLY used 600s anyway, and your 500SS is not immune to "normal" two-stroke failures...

contrary to all the CRAP you read!

ride it, if it breaks fix it!
[snapback]295690[/snapback]​
Curioius to know what 'PROPER' use is? Is that in the manual?!?
 

·
734 Power
Joined
·
2,600 Posts
the old small block 600's are a very tough motor, have yet to hear of ring failure problems on them.
 

·
Just the Tip!!
Joined
·
2,504 Posts
Still runnin stronger than ever 1900 miles, still holdin down the fort.
 
1 - 9 of 9 Posts
Top