Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
739 Posts
Discussion Starter · #1 ·
Got a question for everyone has anyones battery died and rer not worked because of the battery? My bro has a 04 600ho with ele start and rer and the batt is dead and now the rer wont work , is the batt the reason or is it something else?
thanks
ckoz
 

·
Registered
Joined
·
335 Posts
ckoz71 said:
Got a question for everyone has anyones battery died and rer not worked because of the battery? My bro has a 04 600ho with ele start and rer and the batt is dead and now the rer wont work , is the batt the reason or is it something else?
thanks
ckoz
[snapback]282926[/snapback]​
put a battery charger or jumper cables on battery and try it. if it works its the batery
 

·
Registered
Joined
·
39 Posts
ckoz71 said:
Got a question for everyone has anyones battery died and rer not worked because of the battery? My bro has a 04 600ho with ele start and rer and the batt is dead and now the rer wont work , is the batt the reason or is it something else?
thanks
ckoz
[snapback]282926[/snapback]​
I don't belive they are related... Non electric start 600HO's dont' have battery and have RER. I'd check a fuse first... Open the left side panel (clutch side) and there are a couple fuses on the frame above the motor. Check there first.
 

·
Registered
Joined
·
40 Posts
I'm not sure the battery has anything to do with the rer. There are alot of sleds around with rer that do not even have a battery. My 05 600 X is one of them.
 

·
Advanced......dat's how ah roll.
Joined
·
1,950 Posts
What exactly is happening? Does the sled just keep running? Or does it shut off and not restart? Or what? If it shuts off and doesn't restart I think thats the first sign of bad rings.
 

·
Registered
Joined
·
398 Posts
rockwaters18 said:
I'm not sure the battery has anything to do with the rer. There are alot of sleds around with rer that do not even have a battery. My 05 600 X is one of them.
[snapback]282965[/snapback]​
Try blipping the throttle a bit. If the idle is too low sometimes it won't engage.
 

·
Registered
Joined
·
487 Posts
Afriend of mine had same problem. Took off cap on center of handle bars. The plugs for all handle bar accessories are right there unplug them and plug them back in. It worked for us.
 

·
Registered
Joined
·
412 Posts
the idle must be 1500 or 1800 rpm in order for the motor to restart, check your idle and give the idle screw a little turn if its low.
 
1 - 8 of 8 Posts
Top