Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have noticed last night that my rear suspension is not returning to original height on my 2000 Mxz 800 I'm new at this have no idea on what adjustment is need or if something needs replaced. I tried adding the pic but was unsuccessful.
 

·
Registered
Joined
·
6,622 Posts
Is the shock frozen? Take the sled in the garage and thaw it out and see if it returns then. If it does the shock is shot and either needs rebuilt or replaced. If that doesn't solve the problem, something is potentially bent causing a bind. Did you hit anything or land hard or funny???
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks Skampo. I have it in the garage and have it thawing out, it's sitting about in the middle, it went down like that last night and came back up, when I got home it was down again. I haven't hit anything, only a few small jumps nothing crazy or big.
 

·
Registered
Joined
·
7 Posts
I'm dealing with the same thing right now on my 03 mxz zx. I broke a rear arm spring. heard a metallic "ting" noise, seat dropped and didn't come back up.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I heard a similar noise for a few than it quit. When we got back to my friends house it sat back normal
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
I'm going to grease it also, I bought it in January, and the guy told me itwas all greased and ready to hit the trails . So I really do not know!!
 
1 - 8 of 8 Posts
Top