Ski-Doo Snowmobiles Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
I was able to put on 900 miles this last week and have somethings to share.
The sled ran very good from full tank to empty . it averaged around 15mpg
some tank fulls were 17mpg. I was running with a attak and a f7 pro and a indy 700 . we switched around from sled to sled and i can say that I really prefered the gade over all the others . however the yamaha has one hell of a motor.
Problems that i had in the run was i blew two fuses that went to erave,tail light ,
handle bar warmers and thumb warmer. I don't know why ,it would just blow
at start up, the light would flash on the gauges . and it wouldn't rev over 7000
rpm. the other problem that has to be worked on is the head gasket is leaking
.so my recomendation is to torque your head early in sleds mileage.
Now for something BRP needs to look at is the rich condition of which this sled
ran ,my side panel is black over 8" up on right side of the sled from exhaust
at least 2feet back It is BAD Rich . I have never seen this much black on a
sled in my life. As for top end 0-100mph this sled flies . this is NOT a triple
diget sled .Sometimes 102 sometimes 108 .I never could get it to run above
100 the same way twice! i could run it up ,then back out of it and run it up to
100 again and it just stops pulling. I could not beat the attak which didn't please
me . So for the most part this is one hell of a sled , corners like on rails ,takes the bumps better then the rest ,good on fuel,(only 4stoke was better )
I was glad to be able to run with these other sleds .It made me happy with what i
have purchased. all updates are done 2006-1 , and antifreeze plate.
 

·
Registered
Joined
·
236 Posts
Good info. Don`t understand the top end though. Rode with a new Gade with 1500 miles on this weekend. On ice he got 113 on GPS. I got 114.3 with my 06 mach. Fuel consumption was identical. At night when he lets off after hammerin on it, it blows a handsome roman candle out of the exhaust. His panels are covered too.
 

·
Registered
Joined
·
883 Posts
top end sounds way off! Try clicking down (regardless of where you are now).
where are you now?
Yeah, Handling on these things is outstanding!!!!!! NO ski lift at all - even at high speeds
 

·
Registered
Joined
·
44 Posts
That sums up my experience as well, except I am only getting 10mpg, I have had all the updates that were just done so I will see if anything changes. They did have to adjust my e-rave cables which will hopefully resolve an intermittent check engine light. And maybe help fuel economy?
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #5 ·
Started out with the clutch setup on 1
It would run about 101mph -102 mph and tach out at 7500 max
Switched it to 3 and tach went to 7800-7900 105-108
My problem is that it runs different each pull sometimes pull right past 100
Other times it would creep past .All in all she still pulls outstanding to the C note.
I would love to see the side of my sled not turn into a black panel sled .
Original plugs. And I really do like this sled!!! 1100 miles
 

·
Registered
Joined
·
347 Posts
R BEE said:
Started out with the clutch setup on 1
It would run about 101mph -102 mph and tach out at 7500 max
Switched it to 3 and tach went to 7800-7900 105-108
My problem is that it runs different each pull sometimes pull right past 100
Other times it would creep past .All in all she still pulls outstanding to the C note.
I would love to see the side of my sled not turn into a black panel sled .
Original plugs. And I really do like this sled!!! 1100 miles
[snapback]696200[/snapback]​
i feel about the same, love the sled, hate the inconsistensy of the performance...1900 miles so far
 

·
Registered
Joined
·
893 Posts
R BEE said:
Started out with the clutch setup on 1
It would run about 101mph -102 mph and tach out at 7500 max
Switched it to 3 and tach went to 7800-7900 105-108
My problem is that it runs different each pull sometimes pull right past 100
Other times it would creep past .All in all she still pulls outstanding to the C note.
I would love to see the side of my sled not turn into a black panel sled .
Original plugs. And I really do like this sled!!! 1100 miles
[snapback]696200[/snapback]​
the black is from oil. Set your oil for 160mi to 180mi per liter.
 

·
Registered
Joined
·
347 Posts
dooit2it said:
R BEE said:
Started out with the clutch setup on 1
It would run about 101mph -102 mph and tach out at 7500 max
Switched it to 3 and tach went to 7800-7900 105-108
My problem is that it runs different each pull sometimes pull right past 100
Other times it would creep past .All in all she still pulls outstanding to the C note.
I would love to see the side of my sled not turn into a black panel sled .
Original plugs. And I really do like this sled!!! 1100 miles
[snapback]696200[/snapback]​
the black is from oil. Set your oil for 160mi to 180mi per liter.
[snapback]696441[/snapback]​
no its not oil, its fuel........
 

·
Ready for flight
Joined
·
2,505 Posts
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
 

·
Registered
Joined
·
55 Posts
Rockitman said:
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
[snapback]697013[/snapback]​
The Gade is a good sled, but an Apex will blow it away, without the problems. Turn the key and go. They don't even have a hood to open. It's like a car or truck, as far as maintenance.

No belts, no oil, no plugs. Just ride.
 

·
Registered
Joined
·
893 Posts
apexyooper said:
Rockitman said:
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
[snapback]697013[/snapback]​
The Gade is a good sled, but an Apex will blow it away, without the problems. Turn the key and go. They don't even have a hood to open. It's like a car or truck, as far as maintenance.

No belts, no oil, no plugs. Just ride.
[snapback]697117[/snapback]​
I've got two good yammie techs that have their "edit for bad language" together and they can't haul gas to any renegade 1000 i've seen them run, including mine.

No way, a properly 'broke in' gade 1000 is going to have a problem with a 4 stroke yammie. and spare me the talk about the maps and the timing, its not hurting this sled. Its all about setup and it always has been with any sled, or any brand for that matter.
 

·
Ready for flight
Joined
·
2,505 Posts
dooit2it said:
apexyooper said:
Rockitman said:
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
[snapback]697013[/snapback]​
The Gade is a good sled, but an Apex will blow it away, without the problems. Turn the key and go. They don't even have a hood to open. It's like a car or truck, as far as maintenance.

No belts, no oil, no plugs. Just ride.
[snapback]697117[/snapback]​
I've got two good yammie techs that have their "edit for bad language" together and they can't haul gas to any renegade 1000 i've seen them run, including mine.

No way, a properly 'broke in' gade 1000 is going to have a problem with a 4 stroke yammie. and spare me the talk about the maps and the timing, its not hurting this sled. Its all about setup and it always has been with any sled, or any brand for that matter.
[snapback]697170[/snapback]​
Well I guess you work for SkiDoo and it's my fault that my sled is a turd. Well I tried ever setting on the clutch and it wont go over 100 on the speedo and at some setting's it bounced of the rev limiter. My sled would not beat a mxz 600 when I first got it. So you can say your sled was "broke in" properly but my sled was mainly broke in on a stand because it would foul the plugs every time you started it, and it would overheat in about 3 minutes when it was 30 deg. f . How come my dealer ,and another dealer and the tech at SkiDoo doesn't know why my sled is in limp mode and the computer says it has never been in limp mode, they can't reset a fault that in not in the computer but the motor is still in limp mode and the engine light is still blinking. And the tps is all over the place when they hooked it up to the buds computer, but no faults. I'm glad you are happy with your sled. I'M NOT! I'm not happy spending $11,000.00 plus $2,000 in extras clothing, studs, gas can,bag , windsheild, extra guages (that should have been stock) 12 volt outlet's mirrors.etc.... and having it not preform like it should, and then breaking down. I've been riding 3 times this year and it has been nothing but bad,and missed 1 time because of it being in the shop. If you bought a new car and it was a Corvette that wouldn't beat a VW you would be "edit for bad language" too.
 

·
Registered
Joined
·
8,113 Posts
it is no surprise that here a few bad ones and it always sucks to be the one that gets one...

but to not be able to fix it is a joke!

if a guy gets a bad one, it needs to be fixed and right if it means sending a new motor, so be it... and how can they not figure out the problem ?? *%@!

and a 100 mph for a 1000 cc sled? I thought the Mach guys were getting 120+?

Still seems odd to me that some guys buy new sleds year after year and always have problems and others buy sleds year after year with NO problems... ??? how can that be?
 

·
Registered
Joined
·
883 Posts
Im one w/o problems. My gade rocks!!!!! I feel bad for those like rockitman but like I posted a while back on all the BRP bashing - Quit cyring the blues here REPEATEDLY. We cant help you. Only your dealer can help you. And if he wont - find another one. I agree with viper that if your sled doesnt run - they need to be fixin it! replacing the motor, ecu, etc. dont settle for less. These sleds RIP - so if yours doesnt then #1 know that it can #2 force the dealer to do what it takes.
 

·
Registered
Joined
·
592 Posts
apexyooper said:
Rockitman said:
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
[snapback]697013[/snapback]​
The Gade is a good sled, but an Apex will blow it away, without the problems. Turn the key and go. They don't even have a hood to open. It's like a car or truck, as far as maintenance.

No belts, no oil, no plugs. Just ride.
[snapback]697117[/snapback]​
You must have a darn good car if it dont have to change the oil,belts,plugs
 

·
Registered
Joined
·
1,695 Posts
apexyooper said:
Rockitman said:
Well mine is a POS . Mine went into limp mode but my tail light was working. The clutch let go as well about 3 hours later. My sled is a turd. SkiDoo should fired the idiots who designed this motor. And who decided how to clutch it. I don't care about the E.P.A. excuse they gave us, rather than the truth. They (BRP) sold us a bill of goods. This sled stock should beat everything out there that is stock. Thats what they said, does it NO.
Last year my 05 800 Renegade X melted down due to poor workmanship!!!
[snapback]697013[/snapback]​
The Gade is a good sled, but an Apex will blow it away, without the problems. Turn the key and go. They don't even have a hood to open. It's like a car or truck, as far as maintenance.

No belts, no oil, no plugs. Just ride.
[snapback]697117[/snapback]​
Wrong!!!-----I've run (2) apex sleds this year, one stock and one with clutch kit, how far would you like me to tow them!!!--not even a race!! straight and no b.s.!!!
Gade is awesome when set up properly! apex is nice sled and motor is good but it's not in 1000 sdi league!!! keep dreaming
 

·
Registered
Joined
·
697 Posts
[/quote]
Wrong!!!-----I've run (2) apex sleds this year, one stock and one with clutch kit, how far would you like me to tow them!!!--not even a race!! straight and no b.s.!!!
Gade is awesome when set up properly! apex is nice sled and motor is good but it's not in 1000 sdi league!!! keep dreaming

[snapback]783226[/snapback]​
[/quote]

True Dat!
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top