Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Firstly, I know that these sleds don't get great gas milage to begin with, but, my last 2 runs have given me aprox 6 mpg. Should the oil arm be set to the stock setting, I'm constantly fouling plugs and having to clean my rave valves. I had it tuned by a professional in Nov and he said I should get 10-12 mpg, carbs and rave valves were cleaned and oil setting adjusted. After getting it back it still smokes like a b&^%*&% all the time. Any advice or suggestions would be greatly appreciated....Thanks
 

·
Registered
Joined
·
3,810 Posts
Magnum99 said:
Firstly, I know that these sleds don't get great gas milage to begin with, but, my last 2 runs have given me aprox 6 mpg. Should the oil arm be set to the stock setting, I'm constantly fouling plugs and having to clean my rave valves. I had it tuned by a professional in Nov and he said I should get 10-12 mpg, carbs and rave valves were cleaned and oil setting adjusted. After getting it back it still smokes like a b&^%*&% all the time. Any advice or suggestions would be greatly appreciated....Thanks
[snapback]289606[/snapback]​
You should get at least 10 mpg (My 98 Mach Z gets about 9 to 10 mpg with factory jetting). Are you riding in warm conditions with -30 C jetting by any chance?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Last W.E was -15 C and yesterday started the day @ -11, warmed up to -5, think it was set up not to blow up, thinking about shortening needles, but drive side plug running perfect. maybe even a little on the leaner side, center and mag side are always wetter
 

·
Registered
Joined
·
6,219 Posts
Check your needle position, even one clip on the rich side mileage goes out the window. The oil thing, if you run any less than 100 miles to the quart of oil you are way to rich.
 

·
In Search Of PAH!
Joined
·
1,866 Posts
My 1997 Mach 1 also gets very good mileage. Whenever I have ridden w/ others, I pretty much always take the least amount of gas to fill back up, or I am at least within a half a gallon.

Have ridden with 02 Vipers, 2000-up SRX's and SXr's, 2004 Gade X 600HO SDI, 05 Mach Z, 2000 Mach Z's, 97 Mach Z/I, 2002 MXZ 600, Rev 800HO, 02 ZR 800's, etc...

I am also one of the heaviest riders, and am pretty heavy on the throttle. Jetting is stock, except for 45 pilot jets.

Sounds to me that you have some sort of problem in your carbs. I would either try to bring the sled back to the place that did the work and tell them they did something WRONG, or pull them apart and check to see that everything is correct.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Can anyone tell me the book specs for the oil arm cable adjustment, I'm pretty sure this is one of the main problems . I just finished adjusting it to be aprox 1/16" aft of the alignment mark, but it's still smoking way too much.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top