Ski-Doo Snowmobiles Forum banner
1 - 20 of 43 Posts

·
Registered
Joined
·
381 Posts
Thanks to Rafe and Pete, Let us all give a Big Shout Out to The World Snowmobile Headquarters in Eagle River, Wisconsin for providing this Elite venue to display "OUR" PRS Machine. Outside of some of the racing machines on display I believe this is the only"Consumer" independent front suspension snowmobile on display. It is quite an honor to have this machine displayed with some of these legendary machines.. It's like the museum is introducing the modern day sleds to their venue.

So let us SKI DOO enthusiasts be thankful they picked a PRS machine to represent the next generation of machines worthy enough to be there...

Please contact the Museum to express our gratitude. And please visit the museum and witness what they are doing for our wonderful sport....Thanks Again..........Laddie (collie) Antioch, Illinois
 

·
Registered
Joined
·
1,089 Posts
Nice!

Does she still have the efi set up ? i don't recal ever even seing pics of the setup in brochures back when they were new.
 

·
Registered
Joined
·
381 Posts
This machine was purchased as a carb machine. The EFI was removed by the dealer and converted before it was sold. I guess there were a lot of issues with the EFI system which was designed by Mikuni for Ski Doo.. Could not resolve those issues so Ski Doo recalled all the EFI systems and ordered the dealers to convert any machine in stock and to suggest to customers of purchased machines that they be converted or there would be no warranty. If anyone has a running EFI sled it would be a miracle...........Laddie PS These were very limited build machines
 

·
Registered
Joined
·
4,776 Posts
Discussion Starter · #6 ·
I still see some up here running the EFI system - it would be neat to have the set-up to go with the sled even it it never got installed. I will keep my eyes ope - there are still some around.
 

·
Registered
Joined
·
760 Posts
It's not the parts that are hardest, it's making one with EFI run right. A little ahead of it's time. Sounded good on paper, but never worked well in the real world.
 

·
Registered
Joined
·
2,399 Posts
Polaris and cat were way ahead on EFI development in the 90's, and those were far from perfect.
 

·
Registered
Joined
·
381 Posts
I like it just as it is... It Looks and Runs Great..............Thanks to all for your questions and comments.......Please contact The World Snowmobile Headquarters in Eagle River Wi. and let them know we are grateful for displaying "OUR " Sled in this elite venue. The wife and I will be there this Saturday the 19th. Please visit the facility if you get a chance.............Laddie (collie)
 

·
Registered
Joined
·
4,776 Posts
Discussion Starter · #11 ·
Definitely perfect as is, but if ever the opportunity came up to acquire an EFI set-up for a reasonable price it would be a neat addition to the history of the sled. I would never bother to install it but just as a conversation piece. Just what I would do if I owned one.
 

·
Registered
Joined
·
1,952 Posts
Don't you worry about sun fading (the seat and plastic) when it is sitting by a window or door like that? Or won't it be there that long?
 

·
Registered
Joined
·
381 Posts
Good Point.............I will be there this weekend and I will address this concern. The wall and door face due West so it will get afternoon sun. Thanks for your observation................Laddie
 

·
Registered
Joined
·
381 Posts
Contacted Turbo Pete who has (2) 93' Plus X with the low red windshield and his pins are black. I do have a 93' brochure and the low red is shown with red pins. Now you must remember, my 93" EFI came with a Mid height smoke windshield which the original owner changed to low red as a "Dealer Installed" option. I doo have the original. The museum preferred the low red. If black pins are incorrect I will check with a dealer or auto parts store for something red that matches or simply paint some new pins with the correct shade of nail polish...... Getting the machine into the drug store to match the color could be and issue Yikes!!!!......Laddie
 

·
Registered
Joined
·
4,776 Posts
Discussion Starter · #17 ·
Just have to add that I am not claiming black to be correct - I honestly don't know as the brochure shows red but parts book shows black. Hopefully someone with a definite answer can chime in and let us know. I am curious on this as well. thanks
 

·
Registered
Joined
·
1,089 Posts

·
Registered
Joined
·
381 Posts
Turbo Pete and i are talking about the fasteners which have a Phillips style plastic screw. Not the zip tie thing, Yes mine has the black trim also...Laddie
 
1 - 20 of 43 Posts
Top