Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2,382 Posts
Discussion Starter · #1 ·
Got a call tonight, and had to go rescue my buddy's 1200. Seems something let loose inside the pb80 clutchase and ate itself internally and threw all the weight pucks out. Just wondering what others are having for problems and what may have happened. Possible for the spring cup to break then destroy itself or? Will take apart here soon as didn't have time to run aND grab the tools tonight 20160123_183236.jpg
 

Attachments

·
Registered
Joined
·
417 Posts
Happened to mine. PB80 on a 2012. Cup shattered. Clutch had 8000 miles on it...Had to put the traIV back on to finish the season! That had 6000 miles on it with no issues. Luckily I was in my back yard when it went...and that was the day after a 1200 mile Canadian trip!

Called Bill and if I remember correctly he said it had something to do with the harmonics of the 4-stroke and the cup has been redesigned. He sent me a rebuild kit. Very easy to do.
 

·
Registered
Joined
·
709 Posts
I have 25,000+ miles on mine and counting, knock on wood I have only replaced clutch springs.....
 

·
Registered
Joined
·
1,005 Posts
I have 25,000+ miles on mine and counting, knock on wood I have only replaced clutch springs.....
Talk about alot a miles, thats great! Spring cups seem to be the weak link so to speak on pb80's, there are alot of redesigns of this clucth, hopefully improving them every time.
 

·
Registered
Joined
·
2,382 Posts
Discussion Starter · #6 ·
Thanks for the replys guys, I'll take apart to verify. Was trying to think how many miles were on this don't think there were over 3k and would only be about 1k if it didn't make a 2 week trip to Canada thay I'm not sure if it was on or not.
 
1 - 6 of 6 Posts
Top