Ski-Doo Snowmobiles Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
283 Posts
With all the Hub Bub over the sliders wearing out too quick, how has your Renegade been on them. My Renegade is on the third set after 1300 miles. If I stretched it out to the last, I may have gotten more out of the first two sets. With as many miles as you have on yours, I'd think you change them out every Friday. But, I started to think about all that SNOW you have up there and maybe things have turned out different for you. Wazzup!
 

·
Registered
Joined
·
21 Posts
SnoProG said:
With all the Hub Bub over the sliders wearing out too quick, how has your Renegade been on them. My Renegade is on the third set after 1300 miles. If I stretched it out to the last, I may have gotten more out of the first two sets. With as many miles as you have on yours, I'd think you change them out every Friday. But, I started to think about all that SNOW you have up there and maybe things have turned out different for you. Wazzup!
[snapback]297174[/snapback]​
Just think its funny...with all the other sleds I have riden with this year......everyone has driven over the same trials, same lakes. There sliders are not wore out? One sled was an 01 MXZX 700, 6000 KM and the other was a 2000 Legend 700.,7000 Km. There sliders are all OK. I think BRP is trying to pass the buck on this one. Good to hear that others are having the same problem.
 

·
Registered
Joined
·
5,793 Posts
SnoProG said:
With all the Hub Bub over the sliders wearing out too quick, how has your Renegade been on them. My Renegade is on the third set after 1300 miles. If I stretched it out to the last, I may have gotten more out of the first two sets. With as many miles as you have on yours, I'd think you change them out every Friday. But, I started to think about all that SNOW you have up there and maybe things have turned out different for you. Wazzup!
[snapback]297174[/snapback]​
The Gade has the SCIII suspension, so thats fine on slides after you add a set of boggie's in the rear.
My MXZ in the SCIII gets 800-1,000 miles with a 1.65 lug track!
 

·
Registered
Joined
·
1,393 Posts
2005 800 Gade X... replaced them at 900 miles. Could have gone another 3-400, but on my way to Canada...

They only wore at the back under the boggie...would another set of boggies help....


It is a bitch changing them...


BRP, why cant they slide out the window like other manufactures doo... answer me that one please..
 

·
Crazy Person
Joined
·
5,615 Posts
SnoProG said:
With all the Hub Bub over the sliders wearing out too quick, how has your Renegade been on them. My Renegade is on the third set after 1300 miles. If I stretched it out to the last, I may have gotten more out of the first two sets. With as many miles as you have on yours, I'd think you change them out every Friday. But, I started to think about all that SNOW you have up there and maybe things have turned out different for you. Wazzup!
[snapback]297174[/snapback]​
SnoProG!


My Gade has been fine on my sliders. I've got the 1.75" track, stock boggie wheel set-up and I'm still on my first set! They are worn about 1/2 way but are holding there. We do have great snow conditions. Most of my wear occurs in the first month of the season and the last month of the season when things are icy.

I'm very happy with my sliders, I run my track pretty loose, and I don't rachet so that's good. My limiter straps are all the way out.

My track took a bit of a beating on Sunday though, I was hill climbing and I was giving her and I spun on a burried stump! Broke a couple of lugs off right down to the cords of the track...ouch. I'll have to keep an eye on that but I think it will be alright.

One time earlier in the year I was breaking trail to the lodge and I had a boggan loaded with fuel and my damned crappy precision ski's at the time dug into a rock with the carbide and I spun down. After that repeated itself 3 times I was "edit for bad language" so I pinned it and got out but lost some chunks on 2 or 3 of my lugs. Temper temper! LOL

I think my track is very durable for what I've put it through. I'm really happy with this sled.
 

·
Registered
Joined
·
5,793 Posts
SWeaverX said:
Just took a look....1,863 and I am ready for my first set. Deadman what wheel kit are you talking about? thx
[snapback]297347[/snapback]​
I just added an extra set of the normal boggies in the rear of my 121.
The Gade may already have those, but I doubt it.
 

·
Registered
Joined
·
3,054 Posts
I added the extra wheels last season, put on over 3200 miles on that set, and there still was 25 percent left. This season 1200 miles on a new set and no noticable wear.
 

·
Crazy Person
Joined
·
5,615 Posts
Indeed.

But why are 'some' SC 3 owners having trouble?

BRP best be making dem dere sliders reel fast - lol - for what's coming.
 

·
Registered
Joined
·
745 Posts
I let my dealer put on the black c7 sliders and the first time out, with good snow conditions, picked up a nice size shaving. I'm talking 1/4 inch wide, 8 inches long and thick enough not to curl up in a ball. Gave it to the dealer to show his rep. next time he's in.
 

·
Registered
Joined
·
1,700 Posts
Here's what my sliders look like after 735 miles. Most of the wear is between the 2 front idler wheels,,,,


Another one,,,


With a little bit of work, they came out through the track windows. I tapered the ends to make it easier the next time.
 

·
Registered
Joined
·
1,700 Posts
Here's a different view,,,



Last one,,,,,
 

·
Crazy Person
Joined
·
5,615 Posts
My sliders are uneven like that - it is normal - except I've still got lots left so they aren't so close to the line.
 
1 - 16 of 16 Posts
Top