Ski-Doo Snowmobiles Forum banner
1 - 20 of 96 Posts

·
Registered
Joined
·
4,194 Posts
Discussion Starter · #1 ·
On my buds fpp stage one kit he says the breather on the valve cover over by the exhaust has sprayed oil all over the place, he said he lost a quart in the first 500 miles because he just added a quart so thats how he knew that. Ideas as to what might be going on?
 

·
Registered
Joined
·
4,194 Posts
Discussion Starter · #7 ·
Cool thanks! He said he is, he said his low oil light came on last weekend on a ride. I warned him he needs to check it per the manual
 

·
Registered
Joined
·
4,194 Posts
Discussion Starter · #9 ·
I was curious why also. He put it on a new sled and we told him not too, not sure if thats why or what. The sled is right at 500 miles now and hes been taking it pretty easy with it
 

·
Registered
Joined
·
4,194 Posts
Motors blown Brent.

How much boost was he pushing? And what fuel?

Also what type of A/F ratio?
Only 3-4 lbs of boost, she was a pooch the couple times i pushed it a little, i told him nothing but the best fuel, meaning best pump gas, sure hope he listened! We had it fairly ritch imo, cruising was the lean spot in the 13's, wot was around 11. We have been waiting to turn the boost up. He says it runs just fine and is heading out tomorrow for a ride
 
G

·
I am talking about one of the gears for the oil pump inside and below the valve. I had to change one a few years ago and my buddy said the same thing as knapp. The motor was fine it just stripped the nylon gear. It was a 09 so not sure if the gear was updated to aluminum or steel.
 

·
Registered
Joined
·
1,911 Posts
They don't push that much oil if the engine is sound.

Put a leakdown on it, you'll find that engine is toast.
Should be exhaust smoke (blue) if it is putting out that much oil. Check for bad turbo seal, or kinked return line.

Got the symptoms of detonation for sure.
 

·
Registered
Joined
·
1,138 Posts
My fpp would oil up that filter on occasion. Most often if I got the sled on its side in deep snow. If he has done this it may be part of the problem.

Fpp kits run ritch 13 at cruise is fine.
 

·
Registered
Joined
·
2,266 Posts
I talked with Brian apparently the clamp that hold the return line on has worn thru the hose causing it to leak oil
 

·
Registered
Joined
·
1,911 Posts
I talked with Brian apparently the clamp that hold the return line on has worn thru the hose causing it to leak oil
That would be fantastic news.
 
1 - 20 of 96 Posts
Top