Ski-Doo Snowmobiles Forum banner
1 - 20 of 23 Posts

·
I GOT THE NEED FOR SPEED !!!
Joined
·
5,179 Posts
did ya crack your nuts on the gas cap??? sorry had to ask

never seen damage like that before. track looks ok tho
 

·
sledhead
Joined
·
2,241 Posts
Geez Jeff, was that just simple mechanical failure? Didn't you break a torsion spring last time I seen you?

Let me know when you want to ride again. BTW, i was serious when i said (on another post) that you ride way too fast. You always ride that fast, or just getting in some practice for the X-Games

No biggie right? You have 9 backup sleds
 

·
Registered
Joined
·
1,406 Posts
Discussion Starter · #10 ·
pasnownut said:
Holy shnikeys. How in the heck did you do that?? Forget some locktite or to snug up a bolt?
Nut
[snapback]698418[/snapback]​
look at the pictures closer... all bolts are still tight. i think the rail broke first and then took out the tunnel and then the torque arm. i havent looked close at the shock yet.. still in pain. between AKRNGDX and i $2300 and couting in damages... not a good weekend at all...
 

·
Registered
Joined
·
1,406 Posts
Discussion Starter · #12 ·
RATED_X said:
that sucks, How messed up are you? Were you testing out the new track off Vine rd?
[snapback]698592[/snapback]​
Hell I didn't wreck! It just failed on a landing (not all that big either) I think the rail must have been cracked from last months damage and I missed it.
The track off Vine rd will be open next week end I think it'll be like $40 or so to run. THere will be more info on here later this week as one of our dootalk members is involved first hand in what is happening over there.
05SDI
 

·
Registered
Joined
·
3,501 Posts
I dont know if you plan on replacing you tunnel or not, but if you are I would consider doing this. Buy a mounting kit for a m-10 suspension and it will cover up the inside or you tunnel. you can find the plates on e-bay right now for like $10. Then what I would do on the outside is get a 2x3 piece of stainless steel and rivit it to the ouside and your back in bussiness.
 

·
Registered
Joined
·
37 Posts
05SDI said:
pasnownut said:
Holy shnikeys. How in the heck did you do that?? Forget some locktite or to snug up a bolt?
Nut
[snapback]698418[/snapback]​
look at the pictures closer... all bolts are still tight. i think the rail broke first and then took out the tunnel and then the torque arm. i havent looked close at the shock yet.. still in pain. between AKRNGDX and i $2300 and couting in damages... not a good weekend at all...
[snapback]698497[/snapback]​
Some Pics from today.
 

Attachments

1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top