Ski-Doo Snowmobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
My Studding job went perfect, The old short tunnel protecters were kinda tuff to get out. Now the new 1" tall protecters will not slide in.
They keep jumping out of the track and wrecking the plastic channel.
The trouble seems to be where the bent in the aluminum channel to hold the original ones in place.
Any thought or first hand experiences would be great.

Thanks
John
 

·
Doo Pilot
Joined
·
1,895 Posts
Are you working in a heated garage? or use a hairdryer or heat gun to warm them up so they bend alittle and a little soapy water .Don't electricute yourself.
Worked for me
Rich
 

·
Registered
Joined
·
162 Posts
Take a flat file and grind the windows in the aluminium piece that the bumper mounts on, bigger. File up towards top so you can put the protectors in straight. Only takes a minute to file.
 

·
Registered
Joined
·
2 Posts
Yea, I know what your talking about. My first one went in fine, second one kept jumping out of track, gouging the tunnel protector. I tried soap and that helped but what finally did it was a helper. I was pushig it in and a buddy layed under the sled on his back and with the handle end of a hammer pushed up on the protector to guide it in straight. Thank god for friends. The more you gouge it the more it wants to follow the gouges and jump out of the slot. Good luck.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #7 ·
Got it !

I cut 2 vertical slits and folded the metal up so that I had a straight shot. With the help of a little lube they went in PERFECT on the 1st try.

Thanks for the help!


 
1 - 7 of 7 Posts
Top