Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter · #1 ·
Well here is the deal, most of you know i got an sc10II suspension and a new 1 1/4" ripsaw track. I just got all new bearings and larger heat exchanger protectors. Now i started to disassemble the sled. I have everything pulled off the chaincase side and it is just holding itself up by the axle. On the speedo side, i removed the cable, and the 3 bolts that hold it to the frame. Now my problem is i was told by the dealer that i didnt even need to remove the chaincase during disassembly that the axle would slide toward the clutch side and i could pull off the track. Well lol it dont work that way. I tried and the sproket hits the tunnel with no more room. So i am assuming that i need to remove the bearing and the part the speedo cable connects to. And then it will slide toward the chaincase side and removal will be easy right? So if so how do i get that bearing off? Any suggestions?

Or am i way off and something else needs to be done? Any help will be appreciated. By the way this is for a 97 formula 500 thanks
mark
 

·
Registered
Joined
·
2,277 Posts
You need to remove the speedo side bearing collar (#12 in this diagram) which will expose the bearing. It will pop off with a little prying. No need to remove the bearing itself.
 

·
Registered
Joined
·
380 Posts
Discussion Starter · #4 ·
thanks i am going to be to busy today but should be able to get to it thursday or friday and i will try prying on the bearing collar.

yes the bearing is out on the chaincase side everything is off. I pulled the whole chaincase off. because i am replacing all the bearings anyways because the sled has alot of miles on it.

I will let you know what happens in the next day or so thanks alot
mark
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top