Ski-Doo Snowmobiles Forum banner
1 - 14 of 14 Posts

·
Mod'n is my thing
Joined
·
6,288 Posts
I looked at the pics on Inglesperformance microfische but it doesn't show the last hookup on the solenoid that controls the raves.

On your carberators there is a small solenoid that has some small black plastic hoses coming out. One comes up from the case for the input impulse. One goes to the raves where it "T"s off to both. The other end of the solenoid has a nipple but I don't know where it goes.

On the SDI sleds it feeds to the throttle bodies...but what does it do on the PTEK?

Picture would be great....thanks, Chuck

If you are out taking pics....a pic of the temp sensor and connector coming out of the head would be appreciated as well.


Anyone put a temp gauge on theirs?
 

Attachments

·
ITs WINTER!
Joined
·
7,500 Posts
did you try the parts finder on BRP's site?

Probably going to show you the same thing but its worth a try.
 

·
ITs WINTER!
Joined
·
7,500 Posts
Ill take a look at mine this afternoon and grab a few pics for you. Ill only be able to put up small crappy pics untill i get home though
 

·
Mod'n is my thing
Joined
·
6,288 Posts
Discussion Starter · #6 ·
Thanks it must be open to atmosphere. I looked everywhere for a fitting.

Now I just need to find how to hook up my temp and fuel gages...Doo changed the plugs on me.

Also need to figure out where the coil plugs into the harness.
 

·
ITs WINTER!
Joined
·
7,500 Posts
OK, yes the nipple on the mag side (must be the one your talking about) is open to atmosphere.

The coil plugs into the big main harness just above it. white wire w/blue stripe and black w/blue stripe. White wire goes to the upper pin and black to the lower.
 

·
Registered
Joined
·
2,523 Posts
Yes open ........... you dont need to change the sensor for the temp gauge on the PTK.......... your harness must be different from the 2005 if it dosent plug right in. The temp plug is located on the PTO side and the fuel is on the opposite..... both conectors look very similar and I think will actually plug into one another........ PM me if you need more information.....................
 

·
ITs WINTER!
Joined
·
7,500 Posts
My sled has all the wiring/plugs for fuel and temp gauges. So unless your putting in aftermarket gauges it sould just be as simple as plugging it in.
 

·
Mod'n is my thing
Joined
·
6,288 Posts
Discussion Starter · #10 ·
Found the coil setup. Same coil as other sleds just doesn't use the harness so had to unhook it.

The wires for the temp/fuel gauges have black 3 pin plugs on them like the one for you tail light. The Temp/fuel gages I have use a grey connector so that's my problem. I'll figure it out.

Thanks for your help.
 

·
ITs WINTER!
Joined
·
7,500 Posts
The '06s have the same black 3 pin plugs, guess that your going to have to slice and splice!
 

·
Mod'n is my thing
Joined
·
6,288 Posts
Discussion Starter · #13 ·
Luckily for me I had two of them black connectors and the terminals in my spare box. Cut off the gray plugs and put on the new black ones.

Now I just need to make sure the wire harness bundle is hooked up right.

thanks again, Chuck
 

·
Flyin Fox Daddy X3
Joined
·
31,333 Posts
REV*BARON said:
Luckily for me I had two of them black connectors and the terminals in my spare box. Cut off the gray plugs and put on the new black ones.

Now I just need to make sure the wire harness bundle is hooked up right.

thanks again, Chuck
[snapback]705881[/snapback]​
Chuck had spare parts in his garage??? No way....


 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top