Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
my 1996 formula 3 600 sometimes wont start right of the bat and sometimes after i ride it for a while it will quit and let it sit for a few minutes it will start i have checked it when it quits and it is not getting spark to any of the plugs does it sound like the cdi or stator just need some input
 

·
Registered
Joined
·
25 Posts
I am rather new to the game but I have a mxz 600 that had a no spark problem with it. When i had some experts (backyard mechanics) look mine over they all said- a cdi is either good or bad it will not go back and forth, and once it goes it is done(need to replce) A stator however will be effected by heat if there is a small crack in the resin and/or the humidity level in the stator housing will effect it. i hope this helps
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
cdn600mxz said:
I am rather new to the game but I have a mxz 600 that had a no spark problem with it. When i had some experts (backyard mechanics) look mine over they all said- a cdi is either good or bad it will not go back and forth, and once it goes it is done(need to replce) A stator however will be effected by heat if there is a small crack in the resin and/or the humidity level in the stator housing will effect it. i hope this helps

[snapback]686409[/snapback]​
yes it helps alot i really dont want my sled sitting in a garage at a dealer for 4 weeks while they wait for parts when i can order it for myself and get them alot quicker thank you for your response
 
1 - 3 of 3 Posts
Top