Ski-Doo Snowmobiles Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
I installed new rollers on secondary due to them not being there any more but now the sled when I took it for a test run will rev out to 8000 rpm then drop down to 6500 rpm. I checked my plugs and wires all is good, not sure what to check now any help would be great thanks
 

·
Registered
Joined
·
5,908 Posts
Did you install the helix properly?

Bump to the top for you. Good Luck.
 
  • Like
Reactions: NLS800

·
Registered
Joined
·
614 Posts
Welcome to dootalk,

Check that you have the helix installed in the right position.

The marks are confusing. Look for the reverse bump that catches the roller.

That's where you want to index it to.

Might be off 90 degrees.

Hope that fixes it for you.

NLS
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #4 ·
Clutches checked out to be good but still having problems holding rpm past 6500, we found my power valves were leaking so we installed new springs and gaskets they are good to go now too. Could it be an electrical issue ? My plugs and caps and wires are all in good shape also. Any one have any more suggestions ?
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #9 ·
Sled is stock and the motor has t been opened up ever I noticed my motor could probably use some motor mounts cause she shakes pretty bad I will keep trying thanks for the help people, any more input would be great
 

·
Registered
Joined
·
121 Posts
How many miles are on your sled? I see this quite a bit when the primary's need to be rebuilt. A worn secondary moveable sheave bushing will cause this problem as well
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #11 ·
The air box won't clip in on the bottom clip if the box was moving and letting more air in then there should be would it go to limp mode and cause my bog ?
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #12 ·
How many miles are on your sled? I see this quite a bit when the primary's need to be rebuilt. A worn secondary moveable sheave bushing will cause this problem as well
Well that might be the inevitablet problem 10000 trouble free km, it might be that time for a motor but I sure would like to finish this year without rebuilding the motor, but it has never been rebuilt so we will see what happens ....
 
1 - 12 of 12 Posts
Top