Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Seeking clues. My 2000 MXZ 600 SB idles fine but @ 2000rpm's it backfires, misfires, sounds rough, sometimes shuts down however when I get past 2000rpm's its fine. I've cleaned carbs, changed fuel, cleaned jets (main and pilot) cleaned fuel pump, etc.... Anyone know whats goin on?
 

·
Registered
Joined
·
523 Posts
nelgdoo said:
Seeking clues. My 2000 MXZ 600 SB idles fine but @ 2000rpm's it backfires, misfires, sounds rough, sometimes shuts down however when I get past 2000rpm's its fine. I've cleaned carbs, changed fuel, cleaned jets (main and pilot) cleaned fuel pump, etc.... Anyone know whats goin on?
[snapback]743148[/snapback]​
Check your reeds and cages?
 

·
Registered
Joined
·
102 Posts
nelgdoo said:
Seeking clues. My 2000 MXZ 600 SB idles fine but @ 2000rpm's it backfires, misfires, sounds rough, sometimes shuts down however when I get past 2000rpm's its fine. I've cleaned carbs, changed fuel, cleaned jets (main and pilot) cleaned fuel pump, etc.... Anyone know whats goin on?
[snapback]743148[/snapback]​
Sounds like ignition to me as its being put under load is when they'll show up, but once youre moving the load decreases, and the wires can handle it. When running you can take a spray bottle w/ water and lightly spray the plug wires and if it sputters etc, youve found the problem. Also if the condition worsens after spraying them good chance theyre it. So check plug wires, boots, plugs (make sure solid resistor type rather than screw on.) Also I hope youre running NGK. My experience has taught me NGK in 2 strokes are a wise thing to do. It maybe fuel related but my experience from what youre describing is ignition related. Especially as youve done most everything fuel related and no change has happened. You can always check for weak spark from the coil to the plug w/ an adjustable gap ign tool, about 15 bucks at NAPA etc. Good luck! & Hope this helps...
 
1 - 3 of 3 Posts
Top