Ski-Doo Snowmobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,703 Posts
Discussion Starter · #1 ·
Just got word from dealer (who is GREAT dealer) that my MPEM will not even allow them to program a new DSS key...

This after I took the sled (Last week to other dealer) and they claim they "flashed it and should have fixed everything"

described my issue as significant loss of power, bog etc. they found a sensor that was bad, claim they flashed it, and said all is good...

well....took it to VERY GOOD DEALER (S&S Sports in Ronan Montana) and well, I had bad rings, they replaced and were trying to figure out why my RER wont work...found rust on the DSS post and tried wiring in a new post, and that did not fix it....tried using hand computer to program, and a stationary one..nothing, came up not working...tried flashing MPEM, and nothing...

Sooo, Here is the saga of the sled....

1. Vacuum was unplugged...I fixedthat
2. O2 sensor was bad (supposedly) and they replaced it ($150+)
3. Rings were toast, and replaced with Chrome rings (warrantied, so $50)

4. Now MPEM is bad, and needs to be replaced...(not warrantied, so like $350 or something)


I wonder if my wrists will handle all the power once all this is fixed!!!!
No wonder I could not hang with the King Cats in our group....
 

·
Registered
Joined
·
1,703 Posts
Discussion Starter · #3 ·
swedesummit said:
1. Vacuum was unplugged...I fixedthat

How do i found the vacuum??
Why i ask is because i recognise the "bogging thing".
[snapback]729854[/snapback]​
here are two links with pics and everything...

Her is link one that started it....
http://www.dootalk.com/forums/index.php?showtopic=86411&st=0

Here is another link with pics on me changing out my pilot jets...

http://www.dootalk.com/forums/index.php?sh...pic=86693&st=15

But I have found there to be three major issues

Had o2 sensor out (replaced)
Had bad Rings (replaced under warranty)
Had Bad MPEM controller (on order being replaced)

So moral of my story, was Ihad LOADS of issues...(for my sled)

Hope these help!! this site is KILLER for figureing things out!!! and TTabs Mod shop is AMAZING!!!!!!!
 

Attachments

·
Registered
Joined
·
2,705 Posts
I'm riding an 04 800REV 151 and I can't believe how much gas this thing goes through. My buddy rides a 06 800REV 159 and burns half the gas I use.
I'm wondering if it might be the sensor that all these carb vacuum lines go to.

I'm running 390 jets, 3500 to 8000 feet, lifted the needles one clip because of all the mid range trail riding we have to doo this year, but why so bad on gas?
 

·
Mod'n is my thing
Joined
·
6,288 Posts
MPEM on warranty?

If not start searching for a used one for half price.

Even a 600 one will work that has RER and DPM. $75 to get it reprogrammed at the Race Dept in Wasau, WI.
Tom Lawrence is the guy.

You could even have him remove the Dess feature if you want.
 

·
Registered
Joined
·
682 Posts
Sounds like too many cooks in the kitchen, find someone who knows how to use their programmer and read bulletins, most dealers don't.
 

·
Registered
Joined
·
1,911 Posts
I heard lots of '06 MPEMs are fry'n bad due to ... their location!! Snow melts off the head lights, drips down behind the hood, and falls down on the electrical connection of the MPEM corroding the contacts and shorting the units. Heard this is a big problem from a local mod guy.

I wounder if you '06 guys might come up with a mod to protect that thing better. DANG! Their $550 beeks new!!!!
 
1 - 7 of 7 Posts
Top