Ski-Doo Snowmobiles Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Dealer says clutching will have to change. Why would it pull 7800 before and now only 7600 tried less helix still 7600. Dealer says it is more efficient now so makes more power?
 

·
Registered
Joined
·
803 Posts
travelor said:
Dealer says clutching will have to change. Why would it pull 7800 before and now only 7600 tried less helix still 7600. Dealer says it is more efficient now so makes more power?
[snapback]303953[/snapback]​
When u say update, do you mean new mapping?
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #4 ·
skidoo09 said:
travelor said:
Dealer says clutching will have to change. Why would it pull 7800 before and now only 7600 tried less helix still 7600. Dealer says it is more efficient now so makes more power?
[snapback]303953[/snapback]​
When u say update, do you mean new mapping?
[snapback]304088[/snapback]​
Yes, all the updates, and programing.
 

·
Registered
Joined
·
808 Posts
Sounds like your dealer is full of it, if you lost RPM you lost power, haven't done mine yet so hope to see more responses, anyone?
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #8 ·
RTDick said:
We are re-clutching now to try to re-gain rpm's
[snapback]306310[/snapback]​
Has anyone had all the new programming done and seen a big gain like I was told? I think mine would run warm enough so wasn't a problem, and throttle was opening all the way, The leaning out jetting may have hurt it. Haven't really road much but sure seems less responsive. And loosing rpm.
 

·
Registered
Joined
·
19 Posts
travelor said:
RTDick said:
We are re-clutching now to try to re-gain rpm's
[snapback]306310[/snapback]​
Has anyone had all the new programming done and seen a big gain like I was told? I think mine would run warm enough so wasn't a problem, and throttle was opening all the way, The leaning out jetting may have hurt it. Haven't really road much but sure seems less responsive. And loosing rpm.
[snapback]307126[/snapback]​
I have had the new programming done and I´m very pleased with the result. Much smoother without those bogs at 5500. Feels more powerful (maybe because the bog is gone). Strange thing is I get 8200 rpm on #1 clicker and only had 7900 before update? It was cold (about -20 degrees celsius and normally I have -5 degrees) on the only day I´ve tried mine since update, maybe that makes a difference? Anyway I havent lost rpm
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #10 ·
kylan said:
travelor said:
RTDick said:
We are re-clutching now to try to re-gain rpm's
[snapback]306310[/snapback]​
Has anyone had all the new programming done and seen a big gain like I was told? I think mine would run warm enough so wasn't a problem, and throttle was opening all the way, The leaning out jetting may have hurt it. Haven't really road much but sure seems less responsive. And loosing rpm.
[snapback]307126[/snapback]​
I have had the new programming done and I´m very pleased with the result. Much smoother without those bogs at 5500. Feels more powerful (maybe because the bog is gone). Strange thing is I get 8200 rpm on #1 clicker and only had 7900 before update? It was cold (about -20 degrees celsius and normally I have -5 degrees) on the only day I´ve tried mine since update, maybe that makes a difference? Anyway I havent lost rpm
[snapback]307242[/snapback]​

A friend just did his and is very pleased, says it pulls way harder. He also says he lost 200 rpm. He is on clicker 1 at 1800' with stock clutching, before over reving at 8000, now 7800 rpm
 

·
Registered
Joined
·
11 Posts
I did the reprogramming on the RT and am running on clicker 4 at 8200 at 3000 to 8000.

Power seems good but hear the peak HP is at 7800...Going to wait for 15 hours before I do anything else...Any suggestions would be helpful

Helisledder
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #12 ·
Whistlerhelisledder said:
I did the reprogramming on the RT and am running on clicker 4 at 8200 at 3000 to 8000.

Power seems good but hear the peak HP is at 7800...Going to wait for 15 hours before I do anything else...Any suggestions would be helpful

Helisledder
[snapback]308845[/snapback]​
Try one or 2 to get rpm down. Do you have low, stock altitude kit?
 

·
Registered
Joined
·
808 Posts
Just a thought, if they had to install starter rings to all sleds, its possible they have a harmonics problem and that might be why they have lowered the rpm, I am going to leave mine alone and install a thermostat kit for now.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #14 ·
banzai said:
Just a thought, if they had to install starter rings to all sleds, its possible they have a harmonics problem and that might be why they have lowered the rpm, I am going to leave mine alone and install a thermostat kit for now.
[snapback]310513[/snapback]​
When doo was testing sleds before thanksgiving, they figured they would add the starter ring to lessen vibration. They added to mine before I got it before thanksgving. It was one of the sleds n the list recall list but the ring gear was one f the wide ones so it was ok
 
1 - 15 of 15 Posts
Top