Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hey guys I asked this question close to spring last yr and I tried all solutions you gave me last spring finally got to try it out this winter. My problem is the leaking oil onto exhaust pipe see pic I have changed the diafram and all gaskets and seals and it is dripping right from bottom as you can see in pic the other side is perfectly fine the other thing to note as I connected with the old owner who built the sled claims to have deleted the dpm and swaped the carbs with a 570 if that make a difference or is true is beyond me what I know is the sled runs amazing and has tons of power right threw the throttle no complaints with how it runs just wondering why it leaks this oil as it is close to belt and after a few hours of riding is helping the clutch slip any suggestions would help thank you PS if it is hard to see I can assure you it is dripping from the bottom of the plastic black piece that says Rave on it not from exhaust joint
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
Ok here is the picture again the oil is only on the bottom of the black Rave cap you can see I swiped the bottom of it with my finger and it drips onto the pipe also just an FYI this is a 2000 mxz 700
 

Attachments

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
This pic is now after a day of not being started after shutting it off and swiping I get a good glob of oil on finger the only thing I did not change was the steel spring on that clamps the bellow down could it be worn out is their anything eles that could cause this if not I will replace them all again maybe I installed them wrong but seems unlikley to get a o ring installed wrong ha-ha
 

·
Registered
Joined
·
4,343 Posts
They're pretty simple to assemble. The only things that can go wrong as I remember anyway are the oring already mentioned, and the gasket which can be installed up side down or backwards as I recall.
 
1 - 6 of 6 Posts
Top