Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
I have a 95 Mach Z 780, runs excellent but I noticed it was leaking oil out of the main oil line so I changed it. First time riding this season was today, it stalled out the first time going through the field. Then the second time it stalled and locked up, couldn't move the clutch or pull the recoil. 30 seconds later it started and still runs amazing but I hear a knocking noise at idle in the center area of engine. Not sure if the oil injection wasn't working, but only driving it a mile shouldn't mess up an engine in my opinion. When I was younger I ran an old Polaris with straight gas for 2 tanks and was fine lol. So I put oil in gas just in case the oil injection wasn't working and drove again. Still starts up instantly and pulls hard just has a knocking noise. Any ideas? I'm guessing a bearing is going out, it also has over 9,000 miles so could just be a coincidence.
 

·
Registered
Joined
·
1,701 Posts
You could be hearing piston knock from worn pistons and or cylinders. It happened to me caused by a worn out oil pump not supplying enough oil. Pull a cylinder and measure the clearances.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #9 ·
Yeah, guess I will sell for parts. Rather get a newer one that invest more money in an older one. Still started up great this morning lol
 

·
Registered
Joined
·
2,517 Posts
Send a PM to MachD. He loves these 780's. He might want it.
Lynn
 
1 - 10 of 10 Posts
Top