Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
309 Posts
My 583's sled key broke off. i had my video cam pack around the handle bars and it pushed against it and the key broke off. so i only have half the key in there and the rest is out in a field. now i have to start it with a screwdriver... can i get a new key or do i have to buy a whole new ignition system?
 

·
Registered
Joined
·
137 Posts
Not sure about the 583 but I lost the key on my 97 polaris and I just left the ignition in the ON position at all times. Might save you from buying ignition.
You should be able to get the key at the dealer.
 

·
Registered
Joined
·
378 Posts
I was in the same position. But I got the sled with it broke. The guy just left it in the "on" position but there was enough "teeth" left on the key to get a new one cut. Cost only $0.99 at local locksmith. Good Luck
 

·
Registered
Joined
·
309 Posts
Discussion Starter · #5 ·
i suppose i could try to get it out.. its my dads sled but those friggin keys stick out like 5 inches and its no wonder they get broken off... alright ill try some of those options. for now it will be in the on position and use the kill switch
 

·
Registered
Joined
·
1,178 Posts
Stesch_s10 said:
i suppose i could try to get it out.. its my dads sled but those friggin keys stick out like 5 inches and its no wonder they get broken off... alright ill try some of those options. for now it will be in the on position and use the kill switch
[snapback]268371[/snapback]​
Let us know the outcome. I've got the same problem right now, with half the key still stuck in the switch and the handle tethered to the sled, I'm trying to figure out if I can get it out and recut.
 

·
Registered
Joined
·
1,178 Posts
Skidoo_rider said:
had that happen to my old 670, took the entire ignition into the blacksmith, he removed the key and cut a new one and then i just installed the ignition and away i went.
[snapback]268500[/snapback]​
I hadn't thought of doooooing that...will do. Thanks.
 

·
Registered
Joined
·
309 Posts
Discussion Starter · #9 ·
i wanted to go for a short quick trip to try my helmet cam out and i couldn't find anysnow and just kept going and going and this was in the dark so it sucked even more... when i got home i just used my kill switch to shut it off.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top