Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Has anyone installed a temperature gauge in a 2006 500 SS?

I just purchased the KIT - Part # 861510900.

However, from doing some searchs on this site, some say you need a new temp sensor, some say you need a new sending unit.

Others say it is just plug and play?

Do I have everything I need in this kit?

The Kit appears to just contain the gauge and the wiring with a plug.

The instructions say nothing about sensors/sending units etc?

Is it just plug and play?

Any help will be greatly appreciated.

Thanks,

Jason
 

·
Registered
Joined
·
492 Posts
Just installed but have yet to try my new temp guage in an 05' GSX 500ss Sport. The Limited comes stock with the guage. All I had to do was drill the mounting hole in the dash, attach the backing bracket and plug the new guage into the factory harness which already had the matching connector right there.

I have yet to Ops check it. My concern is do I have to swap the stock Temp Sensor/harness with the kits new Temp Sensor/harness. The two harnesses are off by one number on the last digit. Otherwise they are identical down to the wire colors.

My model is very close to the Limited which has the temp guage standard so I am going to try it out as is. The worst that will happen is I will get an erronious overheat lamp on my dash. The MXZ models may be a different story though with respect to their Temp Sensors/harnesses.

To change the sensor I will need to cut short a 9/16' open end wrench, there is not much room there. Air box off, carbs on anyhow.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top