Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
282 Posts
Discussion Starter · #1 ·
I had my first ride with the Tempa-flow and it got a bit better gas MPG and the throttle response was much crisper....


I now have a problem with my rev's surging when I stop. Mine usually has it's high idle (Before it calms down) at 2,600....but as I am sitting there is will idle up to 4,000, then drop back down...then back up, and then back down.....I have found that rapping on the throttle works, but I don't know if something is wrong with it.....

I have no idea if it is due to the tempa-flow, may be just coincidental.....


Any help???
 

·
Registered
Joined
·
282 Posts
Discussion Starter · #3 ·
A Tempa-flow is an automatic jetter that hooks into your airbox and taps into your carbs, increases air flow.
 

·
Let it snow, Let it snow, Let it Snow
Joined
·
1,015 Posts
A surging idle many times indicates a lean condition. Did you leave a hose off or maybe something got knocked loose? Jay
 

·
Registered
Joined
·
566 Posts
After hearing about so many carb boot problems, I'd be checking mine real carefully after a high idle problem.

Jon
'03 Rev 600 Sport
 

·
In Search Of PAH!
Joined
·
1,853 Posts
Are you running the stock jets? A friend of mine's sled was doing the same thing. I forget if he jetted up 1 or 2 sizes from stock to get it right.

I would e-mail or call someone at Holtzman to see what they think.
 

·
Fuzzy but not Blue........
Joined
·
10,650 Posts
Where did you mount the body and what it the rest of your installation? I had one on my '03 800 also and had no issues. Jetting was still rich but adjusted the Tempa-Flow and I was golden! Put it on my wife's '05 500ss and had it on my'99 600 MXZ prior to the '03, so its been around!
-Grover
 

·
Registered
Joined
·
282 Posts
Discussion Starter · #9 ·
I mounted the body inside of the main airbox. Let me clarify the surging rev's, it only happens after I slow down, never when starting up. Once I braap the throttle, it calms down and doesn't do it again...until next time I stop. I went from 370 to 390 jets (Per Holtzman's recomendation).

I have brand new boots that were warrantied in spring of 05. I checked the other air fittings, and everything else looks in place.
 

·
Fuzzy but not Blue........
Joined
·
10,650 Posts
Check/clean your pilot jets or go up one size(17.5pj is stock) to a #20 or #25pj and hi idle rpm's will be gone and it will start easier too.
I had the stock 380's in mine and dialed the screw back the body about 1/8th of a turn. I had it mounted in the outer panel box. Keep in mind that it might be warm inside the engine compartment after you sit, this might cause it to run lean for abit until temps equalize when you get going again. -Grover
 
1 - 10 of 10 Posts
Top