Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter · #1 ·
was up riding this weekend with my mxz and i lost the bearing on the inner chaincase on the cog shaft i couldnt belive it i thought for sure i broke a chain because i could move the clutch and when i took the cover off the chain had just come off

luckaly it didnt break the chaincase but the trip before i noticed a ton of metal shavings so i took the cover off and cleaned everything really well and checked it over
when this broke this weekend there was so much metal in the case i couldnt beilive it iam just puzzeled i mean its got oil on it 24/7

sled has 5000 miles
 

·
Registered
Joined
·
1,037 Posts
what were the symptoms before it broke? Did you know right away that something was hosed?

tom01mxz800rev800 said:
was up riding this weekend with my mxz and i lost the bearing on the inner chaincase on the cog shaft i couldnt belive it i thought for sure i broke a chain because i could move the clutch and when i took the cover off the chain had just come off

luckaly it didnt break the chaincase but the trip before i noticed a ton of metal shavings so i took the cover off and cleaned everything really well and checked it over
when this broke this weekend there was so much metal in the case i couldnt beilive it iam just puzzeled i mean its got oil on it 24/7

sled has 5000 miles
[snapback]738365[/snapback]​
 

·
Registered
Joined
·
5,793 Posts
Very common. Fluid gets moisture, and the bearing sits in it.
 
1 - 3 of 3 Posts
Top