Ski-Doo Snowmobiles Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter · #1 ·
Anyone have a detailed thread on this?

I've run maybe 20L in the sled... and 2L of oil already used.
 

·
Registered
Joined
·
7,506 Posts
Anyone have a detailed thread on this?

I've run maybe 20L in the sled... and 2L of oil already used.
Not sure what you mean by 20L on the sled but you can check the adjustment at the cable above the carbs.. should be around 18 mm.

If the pump arm is sticking.. the pump could be worn.
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #7 ·
Your not going to like me.. but I have seen a few oil pump bodys worn so bad that even with the cable maxed out.. the pump is still full rich. :(

How many miles on the pump?
Sled has about 6000 miles on it. I think its probably safe to assume its the original, from the factory and has probably never been serviced.
 

·
Registered
Joined
·
209 Posts
The pump arm doesn't look stuck when inspected. it articulates when throttle applied.

However, when i let go of the throttle. i can go down and push the arm further. it would appear that the spring that is attatched to the arm is worn out.

Is it possible to maybe purchase a new spring somewhere for the pump arm?

i checked brp and couldnt seem to find a breakdown of the pump
 

·
Registered
Joined
·
7,506 Posts
The pump arm doesn't look stuck when inspected. it articulates when throttle applied.
ya but that doesnt mean its not worn out.

But with 6000 miles.. Ive seen them worn a little.. mine were totally gone at 12000.

If your cable is adjustesd correctly and the arm is not sticking.. I cant think of any reason your oil consumption would be so high.. unless your center shaft seals are leaking or the pump is worn out.
 

·
Registered
Joined
·
7,506 Posts
Im in the process now of changing a pump on one of my 03 revs that I put a shortblock in at 12000.

I bought a used pump on ebay with supposedly 900 miles on it at the time because mine was very loose.

The sled now has 17200 and that pump is loose.

So that is about 6300 miles.

Ive got about 5000 miles on my other rev with a bearing mod pump and it is still like new.
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #14 ·
My other rev that I put a shortblock in at 12400 miles had a worn out pump also.

On this sled.. I got the pump rebuilt with a bearing / machining mod and it is still perfect at 17900.
How do i go about getting one/building one of these for myself
 

·
Registered
Joined
·
1,105 Posts
You said you could push arm further down after letting throttle go back to rest? That says to me it's not returning to it's lowest metering point when throttle is released. Mine did this and some brake clean helped get the action back to where it was supposed to be- belt dust, residue, etc was binding things up. Try that first and adjusting cable before taking your pump out for a rebuild, maybe.
Kurt
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #17 ·
You said you could push arm further down after letting throttle go back to rest? That says to me it's not returning to it's lowest metering point when throttle is released. Mine did this and some brake clean helped get the action back to where it was supposed to be- belt dust, residue, etc was binding things up. Try that first and adjusting cable before taking your pump out for a rebuild, maybe.
Kurt
Thanks kurt, il give her a go.
 

·
My Rig may be old, but that don't mean she&#39
Joined
·
708 Posts

·
Registered
Joined
·
209 Posts
This oil pump mod. The pump has to be removed from the sled and be sent out?

Because of this I may run a spring on it for the rest of this season. Getting lots of snow this week.

Thanks red 05
 
1 - 20 of 23 Posts
Top