Ski-Doo Snowmobiles Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1,128 Posts
Discussion Starter · #1 ·
i am running my own light weight arm set up. im on clicker 4 at 8100 rpm. i am running the dalton pin kit and have the max weight installed 25g. i can get a 27 gram insert, but how much would that drop my rpms? i want to be around clicker 3-4 so i have room to drop down when running the juice. even over reving like i am this thng pulls like a freight train.
 

·
Fuzzy but not Blue........
Joined
·
10,679 Posts
Might drop your end force on your spring to reduce your rpm's. -Grover
 

·
Registered
Joined
·
206 Posts
saint1000 said:
i am running my own light weight arm set up. im on clicker 4 at 8100 rpm. i am running the dalton pin kit and have the max weight installed 25g. i can get a 27 gram insert, but how much would that drop my rpms? i want to be around clicker 3-4 so i have room to drop down when running the juice. even over reving like i am this thng pulls like a freight train.
[snapback]740235[/snapback]​
I am not sure how much umf your getting on actual numbers though. We have been getting best results for max speed at short distances around 7600-7800 rpm. Once we get around 8000 it drops off for us. Not sure how the higher RPMs do for longer runs though. I am also running the Dalton pin set with stock arms and I put in 20 grams at the end of the race when the track was all torn up and was running 111.3mph when my 114 set up with 18.3grams was only pulling 110 at the end of the day so I am thinking the 20 grams set up might be faster on fresh icebut ya never know till ya do it. For some reason though I had to drop all the way down to clicker #1 to get the fastest speed with that set up. Should have gone the other way I would have thought. Anyway enough rambling.

My findings
Here is a pic of my beast in action taking 1st place again!!!! heh heh
 

Attachments

·
boost junkie
Joined
·
10,749 Posts
RTRambler

What ramps did you use to win ?

again GREAT job
 

·
Registered
Joined
·
1,128 Posts
Discussion Starter · #5 ·
i may try to chane my spring, but was wondering how much 2 more grams of pin weight would drop my rpms?
 

·
Registered
Joined
·
206 Posts
SKIDOOCHRIS said:
RTRambler

What ramps did you use to win ?

again GREAT job

[snapback]740590[/snapback]​
Unfortunately I don't have the ramps because they came with my Dynoport clutch kit and the numbers are chizzled off. I also have a sled shop spring that I mixed in with the dynoport kit and the thing just exploded. I was supposed to go over and get the entire set up tonight to post but will be going over tomorrow instead.

All I know is with mixing the sled shop clutch kit with the Dynoport kit we went from going 109 mph as a max to pushing almost 115 mph in 1000 ft. I was kind of throwing sh&% together tyring different combos so I am going to have to go to the shop and see exactly what I put in there. We were celebrating after the fact with brews and then the sled went back in the hauler and is stored and a different guys house and I have not been over there yet.
At first we were wondering if the radar was suspect at the Back to the hack race were we pulled the 114.30mph but this weekend we went to the CMSA race in Annandale and pulled 113.03MPH so we knew that the setup was no fluke. To different speed trap systems at two different events with nearly the same results

Once I get more particulars I will post them.
 

·
Registered
Joined
·
689 Posts
Is this set-up good for just ice running RTRAMBLER or can it be trail ridden and raced on snow ? Sounds fantastic on ice. Great job.
 

·
boost junkie
Joined
·
10,749 Posts
RTRambler

I saw you said that you thought you had 16.5 pins but when you weighed it was 18.4 did you have the roller on when you weighed it?

Did you do anything to the secondary?
 

·
Registered
Joined
·
7 Posts
So what you are saying is that bullentin pins dont make any diffrent from bind stock ? I have my Renegade in for first service and the 3 bulletin issues: Cold start, waterpump plate and competition bulletin so can i expekt any diffrent performence after that?

I dont have any issues problems more than that it go easy over 8000 rpm on clicker 3 !

Carefree!
 

·
Registered
Joined
·
206 Posts
Rotaxmadman said:
Is this set-up good for just ice running RTRAMBLER or can it be trail ridden and raced on snow ? Sounds fantastic on ice. Great job.

[snapback]740777[/snapback]​
I have not really seen an defeciencies in back shifting but the dynoport kit was a trail kit that I put in. The secondary is stock. The only thing is the spring I put in was not a dynoport spring it was a sled shop spring and I still don't have the number on that yet.
 

·
Registered
Joined
·
206 Posts
BlueMax said:
Everyone needs to realize RTRambler is racing with a 130 lb rider. His clutch setup will have to be different for a 200 lb rider. Either way his sled is running great speeds for a stock 05 Mach Z.
[snapback]741026[/snapback]​
Yep was a 130lb rider and is usually 1.5 to 2 mph difference in speed ever time we have switched off without changing the set up. So would be looking at speeds of around 111 to 112 mph or so in 1000ft for a 200 plus pound rider I imagine. Like blue max said it would need a little bit of tweeking for a heavy rider but would be in the ball park

 

·
Registered
Joined
·
206 Posts
SKIDOOCHRIS said:
RTRambler

I saw you said that you thought you had 16.5 pins but when you weighed it was 18.4 did you have the roller on when you weighed it?

Did you do anything to the secondary?
[snapback]740883[/snapback]​
Nope just wieghed the pins. Dynoport told me they were 16.5 when I bought the kit but actually wieghed 18.3.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top