Ski-Doo Snowmobiles Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
508 Posts
The metal piece or the plastic piece? It should all slide right off the post.
 

·
Registered
Joined
·
2,450 Posts
Throw it all away and save yourself time and frustration. Buy a new complete OEM unit and install that.
Also, if the metal cap that holds the recoil together is missing, you need to find it.
Get a magnet, or vacuum or compressed air in behind the flywheel and blow out any debris. It can bounce around and take out your stator.
 

·
Registered
Joined
·
348 Posts
Throw it all away and save yourself time and frustration. Buy a new complete OEM unit and install that.
Also, if the metal cap that holds the recoil together is missing, you need to find it.
Get a magnet, or vacuum or compressed air in behind the flywheel and blow out any debris. It can bounce around and take out your stator.
. X2 on this the rebuild kits are garbage infact I'd buy a used recoil before I'd ever rebuild one again .. I think if you could find one out of a 05 - 07 Mach Z they are metal no plastic crap. Rebuilding one is asking for stator issues .. Been there done that ..

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #9 ·
Throw it all away and save yourself time and frustration. Buy a new complete OEM unit and install that.
Also, if the metal cap that holds the recoil together is missing, you need to find it.
Get a magnet, or vacuum or compressed air in behind the flywheel and blow out any debris. It can bounce around and take out your stator.
And I have the metal cap

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,604 Posts
That looks like an aftermarket recoil with that metal inside the plastic post....????? I've heard not so good things about some of those...as in they tend to fall apart quickly.
 

·
Registered
Joined
·
2,553 Posts
That recoil looks beyond saving, that center post is very important. I think the others are correct, just get a new one
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #15 ·
Oh and tottaly different topic I think I broke my exhaust temp sensor the engine lights on and it won't rev past 7k.

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,553 Posts
Can I just strip everything out of it and just throw the cover on...I got e-start

Sent from my iPhone using Tapatalk
I don't see why not. And as far as the temp sensor you can just replace it with a resistor if you don't want to spend money on a new one. You can do some searching quickly to find what size resistor to use. Also there is a duramax temp sensor that can be used and some searching should also give you more info on that
 

·
stuck...
Joined
·
2,867 Posts
You can get a sensor out of duramax for about 20 bucks and it's the same as doos for 200 bucks
 

·
stuck...
Joined
·
2,867 Posts
1 - 20 of 22 Posts
Top