Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
888 Posts
Discussion Starter · #1 ·
After getting some more miles on my rev this past weekend I noticed sometimes that it hangs up at high idle. I did a search and just wanted some confirmation. It hangs at around 3-3500 rpms, sometimes it will be sitting at like 3000 and clime a little by itself, seems very weird to me. Sometimes I can just wack the throttle a little and it will idle down but sometimes this doesnt work. I read some posts that it was just an adjustment with the idle screw and some had to change jets. Is it more than likely just in need of an adjustment? Thanks for any info...

 

·
Registered
Joined
·
50 Posts
Did it idle normal when you got it? Could just be an adjustment as the motor breaks in. It could also be an air leak in the engine or if the pilot jet is restricited more air could be entering via the air pilot circuit. Must still be under warranty, get the dealer involved. You don't want to melt down this new motor.

PS Snowgoer has a nice article this month on the carbs in this machine.
 

·
Registered
Joined
·
888 Posts
Discussion Starter · #6 ·
Well not exactly what I wanted to hear. As I mentioned I dont really have alot of miles on it yet, about 150 and 100 of that was just last weekend and thats when I noticed the high idle so Im hoping its just an adjustment and nothing serious. I will call my dealer though just to make sure, thanks.
 

·
Registered
Joined
·
11 Posts
I also have an '05 600 HO and it does the same thing. It would either idle too high or too low. I went for my 1st ride this weekend and had to open the side cover like 8 times to adjust the idle! I finally got it figured out: when I first stop it will sit there at around 3000+ rpm. If I just wait several seconds it will slowly drop down and then stay constant at around 1800 rpm. It's not erratic at all... it does the same thing all the time now so I know it's not an air leak causing a lean condition. Also, I doubt a lean pilot curcuit would do that either... I'm not a sled expert but on a 2 stroke dirt bike a lean pilot curcuit will cause erratic behavior too - this is predictable.

Do these carbs have throttle position sensors? If so that could be the issue. It can be set up so the revs stay up for several seconds after you let off the throttle so your rpm will be real close to engagement! Makes sense to me.

I'd like to hear from someone more knowledgeable than myslef on this though!
 

·
Registered
Joined
·
1 Posts
hey whats up !!!
I own a 03 rev 600 h.o and it has done the same thing since it was new i have 1300 miles on it .I was recently at a snodeo and was talking to a ski-doo rep from valcour que. and was explaining to him this problem with high idle .he told me in technical terms it was caused by the flat slide carbs not sealing tightly internally .
He also said it was the nature of the beast. I usually flick the choke real quick to bring the idle down .
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top