Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
395 Posts
I would check your idle screw start by backing both of them 1/2 turn and see where that gets you then keep on doing it until you hit 1700 rpms. If it's rich leave it
 

·
The 02 REVOLUTION
Joined
·
3,892 Posts
Check your boots for loose clamps or cracks. Yes, turn out your idle screws evenly on each carb as mentioned. As far as running rich, you can go with smaller mains if you know how to watch your plug color so you don't lean it out. Check this first, the carbs may need soaked and cleaning internally. May need new needle and seats. If it has DPM may be another problem.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
APC said:
Check your boots for loose clamps or cracks. Yes, turn out your idle screws evenly on each carb as mentioned. As far as running rich, you can go with smaller mains if you know how to watch your plug color so you don't lean it out. Check this first, the carbs may need soaked and cleaning internally. May need new needle and seats. If it has DPM may be another problem.
[snapback]285489[/snapback]​
it does have dpm, and thats kinda the way i was looking because it has started doing this between two different rides. problem is i dont know a dam thing about how the dpm works. should i just start with all the carb stuff???
 

·
The 02 REVOLUTION
Joined
·
3,892 Posts
Wouldn't hurt. Also take apart the choke assy. and clean. If all else fails do a search on here and for DPM problems. There was a lenghty topic just recently on it.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
APC said:
Wouldn't hurt. Also take apart the choke assy. and clean. If all else fails do a search on here and for DPM problems. There was a lenghty topic just recently on it.
[snapback]286489[/snapback]​
THANKS!!! i will dig into it and let everyone know what i find.
 
1 - 6 of 6 Posts
Top