Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
i got A 95 mach 1 670 and when i drive my sled slow it jerks and especially when i am turning, thought it was the track but i dont think it is, i took clutch gard off and drove it slow and i saw the primary clutch letting go of the belt ( this is when it tugged) like its grabbing and then letting go for a split second enough to feel a jerk..can anyone help me?
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #3 ·
the belt is in good shape, its like a chug, could the clutch possibly be worn? if so what would be worn out that would cause this, is there a spring i can get that will make me accelerate quicker? like from 20-60 mph? i dont care if i lose 5-10 mph on top
 

·
The 2nd most interesting man in the world
Joined
·
2,936 Posts
Try a new belt , you may not be able to see it but you put a dip in your belt , it doesn't take much , a frozen track and a good blip on the loud lever will doo it . If you are looking for quicker ,longer launch , Get yourself a clutch kit . A kit will usually include primary spring , adj. pin wieghts , secondary spring, helix and sombody that took some time on a cold "edit for bad language" lake for the hot set-up.
 

·
Samsquamch
Joined
·
1,652 Posts
GET a NEW belt !!!
 

·
Registered
Joined
·
79 Posts
Buy a belt!

jwittock670 said:
i got A 95 mach 1 670 and when i drive my sled slow it jerks and especially when i am turning, thought it was the track but i dont think it is, i took clutch gard off and drove it slow and i saw the primary clutch letting go of the belt ( this is when it tugged) like its grabbing and then letting go for a split second enough to feel a jerk..can anyone help me?
[snapback]278632[/snapback]​
 

·
Registered
Joined
·
309 Posts
Check deflection of the belt. Mine was 1/8 under top of the secondaries sheath, so I adjusted it to 1/8th above and it now engages smoothly.
 
1 - 8 of 8 Posts
Top