Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Im Not a ski-doo guy but i got mxz 500 1999..
Its hard starting when its cold out side... In a heated garage it will start day after day. Take it out side ride it around shut it off come back 5 minutes later it doesent want to start...

Does the variable exhaust need any maintence done to it???

What should the compression be???

Crank seals???

Has great spark...

Bad gas?? Ive run probably 10 gallons or so thru it...

dirty carbs??

seems to run great once started...

Just want to make it a one or two pull ride like my arctic cats....

Im the X boat...

Mike
 

Attachments

·
Registered
Joined
·
9,154 Posts
Mike,
Could have a fuel pump going bad. Mine did this, and I finally changed the pump and she starts on one pull all the time now. Make sure carb, all jets, and needle/seat assemblies are CLEAN! Ensure the needle/seats are working properly and not sticking. From there you can check the fuel pump by removing the impulse line from the engine and sucking on it. If you get fuel the pump is bad. Check the choke plungers also. Remove the cable. The plunger bores tend to rust, and create havoc. Look on the bottom of the plungers, the black seal should be in perfect shape. No cuts, tears, peeling. To adjust the choke simply loosen up the 10MM locknut and lenghten/shorten the cable so when you insert the plunger/cable (don't screw it in just test fit for now) assembly you can feel it seat in the plunger bore. Lock down the 10MM locknut, thread the 12 MM fitting back on the carb. That will properly adjust the choke. While doing this make sure the choke is "off", as in the run position. Oh, do the fuel pump test with the engine off, and you might want to wait a few for a smoke.
 

·
Registered
Joined
·
461 Posts
5 minutes isnt enough for it to cool down that much. what will it do if you let it sit out over night and try to start it? after you ride it and shut it off, are you killing it rihgt away? ive heard several people say to let it idle for 30 sec to 1 min. i started doing it to mine & she starts on no more than 4 pulls even on the coldest days. usually in 1 or 2. we jsut had a 20 below day with windchill. granted it was in the garage, its insulated, but not heated and she started rihgt up.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top