Ski-Doo Snowmobiles Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
One of my riding buddies is very POed at Doo. his 06 GSX 600HOSDI Caught on fire while he was riding. The explanation he got from the dealer is that he fludded the machine while starting it, causing excess gas in the exhaust, which caught on fire.

I hear rumers of a lean condition in the fuel mapping at 7000 RPM causing excessive heat in the exhaust.

Has anyone else experienced this condition?

I FEEL LIKE AN ARCTIC CAT RIDER.
 

·
Registered
Joined
·
883 Posts
tj1273 said:
One of my riding buddies is very POed at Doo. his 06 GSX 600HOSDI Caught on fire while he was riding. The explanation he got from the dealer is that he fludded the machine while starting it, causing excess gas in the exhaust, which caught on fire.

I hear rumers of a lean condition in the fuel mapping at 7000 RPM causing excessive heat in the exhaust.

Has anyone else experienced this condition?

I FEEL LIKE AN ARCTIC CAT RIDER.

[snapback]682588[/snapback]​
That is the biggest bull sh&% line ive ever heard from a dealer. How do you flood a SDI on start anyway? That is just Bull sh&%
 

·
Registered
Joined
·
1,406 Posts
Hmm SDI flooded? Hmm isn't that why these engines have fuel injectors to precisely measure the fuel going into the ports? Something's screwy in St. Louie!!

I would like to know more details of exactly how this happened.

Sorry for his loss I hope the dealer and BRP make it right with him!
05SDI
 

·
Registered
Joined
·
521 Posts
Note to self: IF SLED IS ON FIRE, LET IT BURN! I know of an 04 800 ho X that burned right down to nothing, I was there 5 minutes after it happened, and it was already done for. Ski-Doo has a problem here as well, maybe if they check their warrenty issues they might just notice some failures other than just rings and crankcase seals!
 

·
Registered
Joined
·
28 Posts
tj1273 said:
One of my riding buddies is very POed at Doo. his 06 GSX 600HOSDI Caught on fire while he was riding. The explanation he got from the dealer is that he fludded the machine while starting it, causing excess gas in the exhaust, which caught on fire.

I hear rumers of a lean condition in the fuel mapping at 7000 RPM causing excessive heat in the exhaust.

Has anyone else experienced this condition?

I FEEL LIKE AN ARCTIC CAT RIDER. :(
[snapback]682588[/snapback]​
I hope he had insurance. At least he could get book value for it. My dealer is like that too, they just want to buy the sled and come back to buy other stuff like belts and plugs. It's like they couldn't care less if your sled blew up as long as they get their money.
 

·
Registered
Joined
·
616 Posts
Guy's on a GSX, I'm guessing he's not riding like Blair Morgan. How many miles on the machine? Any problems with the sled before it caught fire? Sounds like WARRANTY to me. Doo owes him a new sled. It's been done before.
 

·
Registered
Joined
·
616 Posts
300 miles. Got it.
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #10 ·
The dealer is fixing his sled under warranty(but he is without his ride with no loner) .

The problem is that we don't know why it happened or what will keep it from happening again.

Havn't heard from anyone else who has had this happen. I hope it is an isolated event.

The great milage from the SDI motors means that they must run leaner.

Has anyone else experienced excessive exhaust temp?
 

·
Registered
Joined
·
1,406 Posts
tj1273 said:
Has anyone else experienced excessive exhaust temp?
[snapback]683466[/snapback]​
I know I can't get my SDI's to get as hot underhood temps as my 06 550fs. Heck the 06 MXZx 550f pipe gets hot enough I open the hood after each heat because the hood is MORE then warm to the touch! It was very surprizing the first race! 05SDI
 

·
Registered
Joined
·
13 Posts
i heard that a few 600 sdi engines were having this little fire problem.
from what i have been reading it seems like the problem might be transfering up to the 1000 also.
this is going to be interesting to see how this turns out.
check out the post by early rider in the mach forum
 

·
Registered
Joined
·
454 Posts
The backfire seems a likely explanation. My SDI backfires from time to time, and any unburned fuel would cause a fire if it got into the exhuast.

I actually had this happen to me with my airplane about 12 years ago. Luckily we were on the ground, but I had to toss my 2 year old out of the plane, onto the ground, as he was scared to go outside the airplane, cause of the fire. - and he was blocking my exit.

if the SDI doesnt start there will be excess fuel in the system, and it could easily get into the exhaust ( they dont always start when you jab the starter ).
Touching the throttle at an inoportune time during starting or reversing, seems particularly to induce backfires - ask my wife who had never seen the RER working before and thought the sled was about to die
.
 

·
Registered
Joined
·
8,113 Posts
now I know why you pay less for sleds in the US.
Because alot of the dealers have no clue about fixing them, they just sell them.
sadly its MOST not alot...
(didn't know we paid less either, at least that makes me feel a bit better about bad dealers)

while I am sure you already know what I am going to say...

with a brand new sled, unless you poor gas on it and light it, no fire can be your fault!

if the sled flooded (SDI) its doos fault. if a hose came off and leaked gas and it ignites, its doos fault, muffler full of gas... ??, etc. as long as you made no modifications or alterations to the new sled you have a full claim!

BTW- muffler full of gas sounds like a bomb lucky all you got was a fire!

my advice is to take it to another dealer or call doo yourself. your getting scammed!

just my take!
 

·
Registered
Joined
·
123 Posts
joevella said:
The backfire seems a likely explanation. My SDI backfires from time to time, and any unburned fuel would cause a fire if it got into the exhuast.

I actually had this happen to me with my airplane about 12 years ago. Luckily we were on the ground, but I had to toss my 2 year old out of the plane, onto the ground, as he was scared to go outside the airplane, cause of the fire. - and he was blocking my exit.

if the SDI doesnt start there will be excess fuel in the system, and it could easily get into the exhaust ( they dont always start when you jab the starter ).
Touching the throttle at an inoportune time during starting or reversing, seems particularly to induce backfires - ask my wife who had never seen the RER working before and thought the sled was about to die
.
[snapback]684292[/snapback]​
The "backfire" you hear is the unburnt fuel igniting. There usually isn't any left after the "explosion." The backfire actually tends to put out fires.

Was your A/C fire during start-up? Natually asperated or charged?
 

·
one fast 98 mach-z
Joined
·
1,328 Posts
My 05 600 sdi 05 renagade x model exhuast can glows red red hot at night. blue flames come out exhuast when letting off flipper. sled will not go over 65 mph after 2 miles from cold start.when engine exhuast gets hot sled starts slowing down. been to two dealers. my new spare belt melted above the can,kevlar strands turned black. dealer puts on computer and finds nothing { they claim }. they replaced voltage regulator that overcharged and burnt fuse holder ontop of battery. new part # of voltage reg is differant than removed one{ skidoo must know there was a problem}. dealer replaced can and can sensor.no help.than they replaced all four fuel injectors.no help. I filed a complaint with skidoo and have a file #. I faxed the info to my dealer of the skidoo tech complaint and file # of the problem filed. Dealer suggests I bring the sled back the day after my warrenty expires in two weeks, this is the dealer I bought it from. I read somebody states ignition timing retards when can gets hot reducing horsepower. my 1980 yamaha 340 fan passes this sled after 2 miles when can gets hot. On the second day I picked it up new the sled started slowing down on a straight away during the day. I thought that the sliders were melting becuase it was hard packed and the 1.25 track lifts the sliders farther from the snow. it felt just like when the sliders start to melt and stick to the track,slowing the sled. Had it been at night I would have seen the can glowing red red hot. So now I have had a lemon sled since new with 1500 miles on it that the warrenty ends in 1.5 weeks. anybody having this problem please reply, I am trying to convince my dealer that I am not dreaming up the problem. after leaving sled at dealer for a couple of days they try it out for a half mile fast and say it runs great. but it takes 2 miles going fast before can turns red and sled sloooows down to 65 mph max.
 
G

·
05SDI said:
Hmm SDI flooded? Hmm isn't that why these engines have fuel injectors to precisely measure the fuel going into the ports? Something's screwy in St. Louie!!

I would like to know more details of exactly how this happened.

Sorry for his loss I hope the dealer and BRP make it right with him!
05SDI
[snapback]682630[/snapback]​
You can flood them because there is Flood mode program in the ECm.
 

·
one fast 98 mach-z
Joined
·
1,328 Posts
red red hot
well had the sled out for first time this year. after one mile on rail bed sled goes to limp mode and speedo will not go over 80 mph. above 75% throttle does not make any differance. exhaust can red hot at night. blue flames out exhaust when let off throttle.

I met a rider same 600 sdi sled and 2005 year as mine on portage lake in maine this week end. He has 7000 miles and claims it will run 105 mph on speedo any day all day. I know speedo are off but mine will only do 80 mph after a mile.

chain links broke on last day { crunch crunch } miles on sled 4444 miles exactly when hit brakes after noise heard. weard 4444 and chain had links broke in more than one spot.

I put a larger bottom gear 45 so will put less strain on engine to see if this stops limp mode.

problem since day a got new.

????????????????????????????????????????????????????????????????
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top