Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Mod'n is my thing
Joined
·
6,288 Posts
Discussion Starter · #1 ·
Three cheers for Dootalker's


With the help of a few willing Dootalker's I got the Ptech wire diagram and compared it to the older one to solve my mystery.

I just put a 830 PTech in my 05 race chassis and the tach needle wasn't working.

The race sled comes with just one gauge (like the Summit X sleds) that does everything.

Everything else worked (which amazed me). All it was to fix was to switch pin 7 in the speedo/tach grey connector to pin #4.

Finally now I can hopefully go out and do some riding to tune it in.
I'm starting out with 480 main jets to be safe and will see how the plugs and EGT's are reading.

Thanks again for your help, Chuck
 

·
Registered
Joined
·
1,544 Posts
SkidooSteve12 said:
Need a test pilot?


I'm ready and will doo it for free.

[snapback]711854[/snapback]​
I'd pay to do it!
 

·
Mod'n is my thing
Joined
·
6,288 Posts
Discussion Starter · #4 ·
Steve...you finally get your skid back in and the sled ready to go?

I'm going to go up to the UP next weekend HOPEFULLY from Friday eve to Tuesday...I need to ride baaaaaaaaad!
 

·
Flyin Fox Daddy X3
Joined
·
31,304 Posts
I'm going to finish it up tonight. I was gone most of the day yesterday, instead of riding we went out and bought a new car, 06 Malibu Maxx. Then today was my wife's birthday so went out to lunch with the family and shopping.

I need to get out next weekend too. Not sure where I'll be as we are getting some snow locally finally.
 
1 - 5 of 5 Posts
Top